summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/ascii-invaders/ascii-invaders-0.1b-r1.ebuild')
-rw-r--r--games-arcade/ascii-invaders/ascii-invaders-0.1b-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-arcade/ascii-invaders/ascii-invaders-0.1b-r1.ebuild b/games-arcade/ascii-invaders/ascii-invaders-0.1b-r1.ebuild
new file mode 100644
index 000000000000..5c6a25c0ed44
--- /dev/null
+++ b/games-arcade/ascii-invaders/ascii-invaders-0.1b-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Space invaders clone, using ncurses library"
+HOMEPAGE="https://packages.gentoo.org/package/games-arcade/ascii-invaders"
+SRC_URI="mirror://gentoo/invaders${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc64 ~x86 ~x86-fbsd ~ppc-macos"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/invaders"
+
+src_prepare() {
+ default
+ rm -f Makefile
+}
+
+src_compile() {
+ emake LDLIBS="$(pkg-config ncurses --libs)" invaders
+}
+
+src_install() {
+ newbin invaders ${PN}
+ einstalldocs
+}