summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/betna')
-rw-r--r--games-arcade/betna/Manifest1
-rw-r--r--games-arcade/betna/betna-0.9.7.ebuild47
-rw-r--r--games-arcade/betna/metadata.xml5
3 files changed, 53 insertions, 0 deletions
diff --git a/games-arcade/betna/Manifest b/games-arcade/betna/Manifest
new file mode 100644
index 000000000000..f9f2408d49df
--- /dev/null
+++ b/games-arcade/betna/Manifest
@@ -0,0 +1 @@
+DIST betna-0.9.7.tgz 684723 SHA256 312267ab2f727e91343673b832d243c9d8a16a744d1d104c4bbe8502268beff4 SHA512 01a979b3bd5adf1581293db8a066a4db1b4818f5986d8954d0da5d1e1eb394201c2affcee8c679b7cd23b4d255f718619dc00183b59fe7be280f18db0c0548d5 WHIRLPOOL b4ff9b2c3890775460e6f35fee3436d587884088d1ee4267ec0f44b92d68f6703c3bc2c175aad1ba56f656069033f8ec3346dafd86bc73bfc8f92a81a1e03ac6
diff --git a/games-arcade/betna/betna-0.9.7.ebuild b/games-arcade/betna/betna-0.9.7.ebuild
new file mode 100644
index 000000000000..d34055d8f8ff
--- /dev/null
+++ b/games-arcade/betna/betna-0.9.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils games
+
+DESCRIPTION="Defend your volcano from the attacking ants by firing rocks/bullets at them"
+HOMEPAGE="http://koti.mbnet.fi/makegho/c/betna/"
+SRC_URI="http://koti.mbnet.fi/makegho/c/betna/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e '/blobprintf.*char msg/s/char msg/const char msg/' \
+ -e "s:images/:${GAMES_DATADIR}/${PN}/:" \
+ src/main.cpp || die
+
+ sed -i \
+ -e '/^LDFLAGS/d' \
+ -e '/--libs/s/-o/$(LDFLAGS) -o/' \
+ -e 's:-O2:$(CXXFLAGS):g' \
+ -e 's/g++/$(CXX)/' \
+ Makefile || die
+}
+
+src_compile() {
+ emake clean
+ emake
+}
+
+src_install() {
+ dogamesbin betna
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins images/*
+ newicon images/target.bmp ${PN}.bmp
+ make_desktop_entry ${PN} Betna /usr/share/pixmaps/${PN}.bmp
+ dodoc README Q\&A
+ prepgamesdirs
+}
diff --git a/games-arcade/betna/metadata.xml b/games-arcade/betna/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/betna/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>