summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/lbreakout/lbreakout-010315.ebuild')
-rw-r--r--games-arcade/lbreakout/lbreakout-010315.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-arcade/lbreakout/lbreakout-010315.ebuild b/games-arcade/lbreakout/lbreakout-010315.ebuild
new file mode 100644
index 000000000000..d6afbc499bfe
--- /dev/null
+++ b/games-arcade/lbreakout/lbreakout-010315.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+inherit games
+
+DESCRIPTION="Breakout clone written with the SDL library"
+HOMEPAGE="http://lgames.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lgames/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.1.5"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e '/^sdir=/s:$datadir/games:$datadir:' \
+ -e '/^hdir=/s:/var/lib/games:$localstatedir:' \
+ configure \
+ || die "sed failed"
+}
+
+src_install() {
+ dodir "${GAMES_STATEDIR}"
+ default
+ dohtml lbreakout/manual/*
+ prepgamesdirs
+}