summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/openmortal/openmortal-0.7-r1.ebuild')
-rw-r--r--games-arcade/openmortal/openmortal-0.7-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/games-arcade/openmortal/openmortal-0.7-r1.ebuild b/games-arcade/openmortal/openmortal-0.7-r1.ebuild
index c24d9f4a932b..9dcc163dc3f7 100644
--- a/games-arcade/openmortal/openmortal-0.7-r1.ebuild
+++ b/games-arcade/openmortal/openmortal-0.7-r1.ebuild
@@ -21,20 +21,20 @@ DEPEND="media-libs/libsdl[video]
media-libs/sdl-net
>=media-libs/freetype-2.4.0
dev-lang/perl"
-RDEPEND="${DEPEND}"
+RDEPEND=${DEPEND}
src_prepare() {
epatch \
"${FILESDIR}/${P}"-gcc41.patch \
"${FILESDIR}/${P}"-freetype.patch
-
+ mv configure.{in,ac} || die
eautoreconf
}
src_install() {
- emake DESTDIR="${D}" install
+ DOCS="AUTHORS ChangeLog README TODO" \
+ default
newicon data/gfx/icon.png ${PN}.png
make_desktop_entry ${PN} OpenMortal
- dodoc AUTHORS ChangeLog README TODO
prepgamesdirs
}