summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/supertux/files/supertux-0.4.0-squirrel.patch')
-rw-r--r--games-arcade/supertux/files/supertux-0.4.0-squirrel.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/games-arcade/supertux/files/supertux-0.4.0-squirrel.patch b/games-arcade/supertux/files/supertux-0.4.0-squirrel.patch
new file mode 100644
index 000000000000..09824425dede
--- /dev/null
+++ b/games-arcade/supertux/files/supertux-0.4.0-squirrel.patch
@@ -0,0 +1,20 @@
+--- supertux-0.4.0.orig/external/squirrel/CMakeLists.txt
++++ supertux-0.4.0/external/squirrel/CMakeLists.txt
+@@ -65,8 +65,6 @@
+
+ # the squirrel sources are out of our control so don't be too pedantic about
+ # them
+-SET(CMAKE_CXX_FLAGS "")
+-SET(CMAKE_C_FLAGS "")
+
+ ## define a target for building the library
+
+@@ -82,8 +80,3 @@
+ set(LIB_SUBDIR "lib${LIB_SUFFIX}"
+ CACHE STRING "Subdirectory of prefix into which libraries are installed (e.g., lib32, lib64)")
+
+-INSTALL(TARGETS squirrel
+- RUNTIME DESTINATION bin
+- ARCHIVE DESTINATION ${LIB_SUBDIR}
+- LIBRARY DESTINATION ${LIB_SUBDIR}
+- COMPONENT squirrel)