summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/afternoonstalker/afternoonstalker-1.1.5-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-arcade/afternoonstalker/afternoonstalker-1.1.5-r1.ebuild b/games-arcade/afternoonstalker/afternoonstalker-1.1.5-r1.ebuild
new file mode 100644
index 000000000000..f7f3afc9f23e
--- /dev/null
+++ b/games-arcade/afternoonstalker/afternoonstalker-1.1.5-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="Clone of the 1981 Night Stalker video game by Mattel Electronics"
+HOMEPAGE="http://perso.b2b2c.ca/sarrazip/dev/afternoonstalker.html"
+SRC_URI="http://perso.b2b2c.ca/sarrazip/dev/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-games/flatzebra-0.1.6"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "/^pkgsounddir/ s:sounds.*:\$(PACKAGE)/sounds:" \
+ -e "/^desktopentrydir/ s:=.*:=/usr/share/applications:" \
+ -e "/^pixmapdir/ s:=.*:=/usr/share/pixmaps:" \
+ src/Makefile.am || die
+ eautoreconf
+}
+
+src_install() {
+ emake -C src DESTDIR="${D}" install
+ doman doc/${PN}.6
+ einstalldocs
+}