summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/balloonchase/balloonchase-0.9.6-r1.ebuild34
-rw-r--r--games-arcade/balloonchase/files/0.9.6-gentoo.patch8
2 files changed, 38 insertions, 4 deletions
diff --git a/games-arcade/balloonchase/balloonchase-0.9.6-r1.ebuild b/games-arcade/balloonchase/balloonchase-0.9.6-r1.ebuild
new file mode 100644
index 000000000000..36976cc63a40
--- /dev/null
+++ b/games-arcade/balloonchase/balloonchase-0.9.6-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop toolchain-funcs
+
+DESCRIPTION="Fly a hot air balloon and try to blow the other player out of the screen"
+HOMEPAGE="http://makegho.mbnet.fi/c/bchase/"
+SRC_URI="http://makegho.mbnet.fi/c/bchase/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${PV}-gentoo.patch
+ sed -i "s:g++:$(tc-getCXX):" Makefile || die
+ sed -i \
+ -e "s:GENTOODIR:/usr/share/${PN}:" src/main.c || die
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins -r images
+ newicon images/kp2b.bmp ${PN}.bmp
+ make_desktop_entry ${PN} "Balloon Chase" /usr/share/pixmaps/${PN}.bmp
+ einstalldocs
+}
diff --git a/games-arcade/balloonchase/files/0.9.6-gentoo.patch b/games-arcade/balloonchase/files/0.9.6-gentoo.patch
index 55e978850bbe..ff232693422b 100644
--- a/games-arcade/balloonchase/files/0.9.6-gentoo.patch
+++ b/games-arcade/balloonchase/files/0.9.6-gentoo.patch
@@ -1,5 +1,5 @@
---- Makefile
-+++ Makefile
+--- a/Makefile
++++ b/Makefile
@@ -1,4 +1,3 @@
-LDFLAGS= -lSDL -lpthread -s
CFLAGS= -Wall # -DDEBUG
@@ -16,8 +16,8 @@
pkg:
@echo $(PKG_BCVERSION) >VERSION
rm balloonchase src/*.o
---- src/main.c
-+++ src/main.c
+--- a/src/main.c
++++ b/src/main.c
@@ -333,47 +333,47 @@
int InitImages()