summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/biloba')
-rw-r--r--games-board/biloba/Manifest1
-rw-r--r--games-board/biloba/biloba-0.9.3.ebuild52
-rw-r--r--games-board/biloba/files/biloba-0.9.3-no-X11-dep.patch17
-rw-r--r--games-board/biloba/files/biloba-0.9.3-not-windows.patch15
-rw-r--r--games-board/biloba/metadata.xml8
5 files changed, 93 insertions, 0 deletions
diff --git a/games-board/biloba/Manifest b/games-board/biloba/Manifest
new file mode 100644
index 000000000000..e91ed216e5e8
--- /dev/null
+++ b/games-board/biloba/Manifest
@@ -0,0 +1 @@
+DIST biloba-0.9.3.tar.gz 3162976 SHA256 a088d91bf1df8e2df643da95b5b55494dca82e5e64f28b2ffa9308bd47e12c61 SHA512 8729299bb37e05b7c27e0d77d022228c385d3d3c475c77b9b8eb81a6df2c2513ea0055b52b65715922fd964e4bab875e3ab5bec58746095346bf0c96d0cf6bc5 WHIRLPOOL 6cbadee65355b18492f67bc47287fc48ea56c90cb18d39b2df80c977180f3098aae9b7a1d183c033ee5d04e4e48adee0a0659d97d134fed6843847026a7bb344
diff --git a/games-board/biloba/biloba-0.9.3.ebuild b/games-board/biloba/biloba-0.9.3.ebuild
new file mode 100644
index 000000000000..35cc345b6fcd
--- /dev/null
+++ b/games-board/biloba/biloba-0.9.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils gnome2-utils games
+
+DESCRIPTION="a board game, up to 4 players, with AI and network"
+HOMEPAGE="http://biloba.sourceforge.net/"
+SRC_URI="mirror://sourceforge/biloba/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl:0[X,video,sound]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ # X11 headers are checked but not used, everything is done through SDL
+ epatch \
+ "${FILESDIR}"/${P}-not-windows.patch \
+ "${FILESDIR}"/${P}-no-X11-dep.patch
+
+ # "missing" file is old, and warns about --run not being supported
+ rm -f missing
+ eautoreconf
+}
+
+src_install() {
+ default
+ newicon -s 64 biloba_icon.png ${PN}.png
+ make_desktop_entry biloba Biloba
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-board/biloba/files/biloba-0.9.3-no-X11-dep.patch b/games-board/biloba/files/biloba-0.9.3-no-X11-dep.patch
new file mode 100644
index 000000000000..4c4ef50776cb
--- /dev/null
+++ b/games-board/biloba/files/biloba-0.9.3-no-X11-dep.patch
@@ -0,0 +1,17 @@
+--- configure.ac.orig 2006-07-29 11:38:43.000000000 +0200
++++ configure.ac 2006-07-29 11:40:52.000000000 +0200
+@@ -40,14 +40,6 @@
+ ;;
+ *)
+ MATHLIB="-lm"
+- AC_PATH_X
+- AC_PATH_XTRA
+- if test x$have_x = xyes; then
+- CFLAGS="$CFLAGS $X_CFLAGS"
+- SYS_GL_LIBS="$X_LIBS -lGL"
+- else
+- SYS_GL_LIBS="-lGL"
+- fi
+ ;;
+ esac
+ AC_SUBST(MATHLIB)
diff --git a/games-board/biloba/files/biloba-0.9.3-not-windows.patch b/games-board/biloba/files/biloba-0.9.3-not-windows.patch
new file mode 100644
index 000000000000..c0ed069ffc2d
--- /dev/null
+++ b/games-board/biloba/files/biloba-0.9.3-not-windows.patch
@@ -0,0 +1,15 @@
+--- configure.ac.old 2008-01-14 14:51:11.000000000 +0100
++++ configure.ac 2008-12-28 12:57:13.000000000 +0100
+@@ -73,12 +65,6 @@
+ AC_MSG_ERROR([*** SDL-Mixer not found!]))
+ AC_CHECK_HEADER(SDL/SDL_mixer.h, , AC_MSG_ERROR([*** SDL-mixer devel files not found!]))
+
+-AC_ARG_VAR(WINDRES, [Windows Resource compiler tool path])
+-AC_PATH_TOOL(WINDRES,windres,
+- [AC_MSG_WARN(Could not find a windres tool in your PATH.)]
+-)
+-AC_SUBST(WINDRES)
+-
+ AC_ARG_ENABLE(maemo,
+ [ --enable-maemo build for the Maemo platform [default=no]],
+ [ac_cv_enable_maemo=$enableval], [ac_cv_enable_maemo=no])
diff --git a/games-board/biloba/metadata.xml b/games-board/biloba/metadata.xml
new file mode 100644
index 000000000000..e7b40101147b
--- /dev/null
+++ b/games-board/biloba/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">biloba</remote-id>
+ </upstream>
+</pkgmetadata>