summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/freedoko/files/freedoko-0.7.16-gentoo.patch')
-rw-r--r--games-board/freedoko/files/freedoko-0.7.16-gentoo.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-board/freedoko/files/freedoko-0.7.16-gentoo.patch b/games-board/freedoko/files/freedoko-0.7.16-gentoo.patch
new file mode 100644
index 000000000000..68160dcba926
--- /dev/null
+++ b/games-board/freedoko/files/freedoko-0.7.16-gentoo.patch
@@ -0,0 +1,33 @@
+--- a/src/Makefile.old 2017-06-06 13:30:39.005626983 +0200
++++ b/src/Makefile 2017-06-06 13:31:09.180881871 +0200
+@@ -239,15 +239,7 @@
+ # compile FreeDoko
+ $(PROGRAM) : show_settings objects $(DIRECTORIES)
+ @echo 'compiling $(PROGRAM)...'
+-# Gentoo users do want to see the real compile line.
+-# So remove the next five lines (the echo lines)
+-# and remove the '@' in the line after.
+- @echo '$(CXX) $$(OBJECTS)'
+- @echo ' $(INCLUDE_ALL)'
+- @echo ' $(LIBS_ALL)'
+- @echo ' $(CXXFLAGS)'
+- @echo ' -o $@'
+- @$(CXX) \
++ $(CXX) \
+ $(OBJECTS_ALL:%.o=$(FREEDOKO_WORKING_DIRECTORY)/%.o) \
+ $(INCLUDE_ALL) \
+ $(LIBS_ALL) \
+--- a/src/Makefile.rules.old 2017-06-06 13:30:27.071526137 +0200
++++ b/src/Makefile.rules 2017-06-06 13:31:17.829954904 +0200
+@@ -80,10 +80,7 @@
+ $(DEPTH)/Makefile.modules \
+ $(DEPTH)/Makefile.local \
+ $(DEPTH)/Makefile.os
+-# Gentoo users do want to see the real compile line.
+-# So remove the next line and remove the '@' in the line after.
+- @echo $(CXX) -c $(SUBDIR)/$<
+- @$(CXX) $(INCLUDE) $(CPPFLAGS) $(CXXFLAGS) $(DEPGEN_FLAGS) -o $@ -c $<
++ $(CXX) $(INCLUDE) $(CPPFLAGS) $(CXXFLAGS) $(DEPGEN_FLAGS) -o $@ -c $<
+
+
+ -include $(OBJECTS:%.o=$(TARGET_DIR_LOCAL)%.d)