summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/ppsspp/files')
-rw-r--r--games-emulation/ppsspp/files/ppsspp3
-rw-r--r--games-emulation/ppsspp/files/ppsspp-cmake.patch32
-rw-r--r--games-emulation/ppsspp/files/ppsspp-ffmpeg-x86.patch11
-rw-r--r--games-emulation/ppsspp/files/ppsspp-ffmpeg-x86_64.patch11
-rw-r--r--games-emulation/ppsspp/files/ppsspp-qt.patch11
-rw-r--r--games-emulation/ppsspp/files/ppsspp.desktop7
6 files changed, 75 insertions, 0 deletions
diff --git a/games-emulation/ppsspp/files/ppsspp b/games-emulation/ppsspp/files/ppsspp
new file mode 100644
index 000000000000..7e3da1317aba
--- /dev/null
+++ b/games-emulation/ppsspp/files/ppsspp
@@ -0,0 +1,3 @@
+#!/bin/bash
+cd /usr/share/games/ppsspp
+./PPSSPPSDL
diff --git a/games-emulation/ppsspp/files/ppsspp-cmake.patch b/games-emulation/ppsspp/files/ppsspp-cmake.patch
new file mode 100644
index 000000000000..4a0a036b1d40
--- /dev/null
+++ b/games-emulation/ppsspp/files/ppsspp-cmake.patch
@@ -0,0 +1,32 @@
+--- CMakeLists.txt.orig 2016-01-04 20:44:44.010023206 +0800
++++ CMakeLists.txt 2016-01-04 20:45:34.910024088 +0800
+@@ -219,11 +219,11 @@
+ if(NOT MSVC)
+ set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -g -D_DEBUG")
+ set(CMAKE_CXX_FLAGS_MINSIZEREL "${CMAKE_CXX_FLAGS_MINSIZEREL} -Os -D_NDEBUG")
+- set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -O3 -D_NDEBUG")
++ set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -O2 -D_NDEBUG")
+ set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "${CMAKE_CXX_FLAGS_RELWITHDEBINFO} -O2 -g -D_NDEBUG")
+ set(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -g -D_DEBUG")
+ set(CMAKE_C_FLAGS_MINSIZEREL "${CMAKE_C_FLAGS_MINSIZEREL} -Os -D_NDEBUG")
+- set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -O3 -D_NDEBUG")
++ set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -O2 -D_NDEBUG")
+ set(CMAKE_C_FLAGS_RELWITHDEBINFO "${CMAKE_C_FLAGS_RELWITHDEBINFO} -O2 -g -D_NDEBUG")
+
+ # Disable some warnings
+@@ -634,12 +634,12 @@
+ if (NOT MSVC)
+ # These can be fast even for debug.
+ if(NOT SNAPPY_FOUND)
+- set_target_properties(snappy PROPERTIES COMPILE_FLAGS "-O3")
++ set_target_properties(snappy PROPERTIES COMPILE_FLAGS "-O2")
+ endif()
+- set_target_properties(udis86 PROPERTIES COMPILE_FLAGS "-O3")
+- set_target_properties(cityhash PROPERTIES COMPILE_FLAGS "-O3")
++ set_target_properties(udis86 PROPERTIES COMPILE_FLAGS "-O2")
++ set_target_properties(cityhash PROPERTIES COMPILE_FLAGS "-O2")
+ if(NOT ZLIB_FOUND)
+- set_target_properties(zlib PROPERTIES COMPILE_FLAGS "-O3")
++ set_target_properties(zlib PROPERTIES COMPILE_FLAGS "-O2")
+ endif()
+ endif()
diff --git a/games-emulation/ppsspp/files/ppsspp-ffmpeg-x86.patch b/games-emulation/ppsspp/files/ppsspp-ffmpeg-x86.patch
new file mode 100644
index 000000000000..c9e755ddba67
--- /dev/null
+++ b/games-emulation/ppsspp/files/ppsspp-ffmpeg-x86.patch
@@ -0,0 +1,11 @@
+--- ffmpeg/linux_x86.sh.orig 2016-01-04 21:44:11.540084990 +0800
++++ ffmpeg/linux_x86.sh 2016-01-04 21:44:56.560085770 +0800
+@@ -72,7 +72,7 @@
+ ./configure \
+ --prefix=./linux/${ARCH} \
+ ${GENERAL} \
+- --extra-cflags="-D__STDC_CONSTANT_MACROS -O3" \
++ --extra-cflags="-D__STDC_CONSTANT_MACROS -O2" \
+ --enable-zlib \
+ --disable-yasm \
+ --disable-everything \
diff --git a/games-emulation/ppsspp/files/ppsspp-ffmpeg-x86_64.patch b/games-emulation/ppsspp/files/ppsspp-ffmpeg-x86_64.patch
new file mode 100644
index 000000000000..45bd877919a6
--- /dev/null
+++ b/games-emulation/ppsspp/files/ppsspp-ffmpeg-x86_64.patch
@@ -0,0 +1,11 @@
+--- ffmpeg/linux_x86-64.sh.orig 2016-01-04 21:42:14.220082959 +0800
++++ ffmpeg/linux_x86-64.sh 2016-01-04 21:42:31.940083265 +0800
+@@ -71,7 +71,7 @@
+ ./configure \
+ --prefix=./linux/${ARCH} \
+ ${GENERAL} \
+- --extra-cflags="-D__STDC_CONSTANT_MACROS -O3" \
++ --extra-cflags="-D__STDC_CONSTANT_MACROS -O2" \
+ --enable-zlib \
+ --enable-pic \
+ --disable-yasm \
diff --git a/games-emulation/ppsspp/files/ppsspp-qt.patch b/games-emulation/ppsspp/files/ppsspp-qt.patch
new file mode 100644
index 000000000000..e372f15df813
--- /dev/null
+++ b/games-emulation/ppsspp/files/ppsspp-qt.patch
@@ -0,0 +1,11 @@
+--- Qt/Settings.pri.orig 2016-01-04 21:37:36.600078151 +0800
++++ Qt/Settings.pri 2016-01-04 21:37:57.430078511 +0800
+@@ -64,7 +64,7 @@
+ else: QMAKE_CXXFLAGS += -std=c++11
+ QMAKE_CFLAGS_RELEASE ~= s/-O.*/
+ QMAKE_CXXFLAGS_RELEASE ~= s/-O.*/
+- QMAKE_ALLFLAGS_RELEASE += -O3 -ffast-math
++ QMAKE_ALLFLAGS_RELEASE += -O2 -ffast-math
+ }
+
+ contains(QT_CONFIG, opengles.) {
diff --git a/games-emulation/ppsspp/files/ppsspp.desktop b/games-emulation/ppsspp/files/ppsspp.desktop
new file mode 100644
index 000000000000..a50ed06e145d
--- /dev/null
+++ b/games-emulation/ppsspp/files/ppsspp.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=PPSSPP
+Comment=A PSP emulator
+Exec=/usr/games/bin/ppsspp
+Icon=ppsspp-icon
+Categories=Game;