summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/unreal')
-rw-r--r--games-fps/unreal/Manifest3
-rw-r--r--games-fps/unreal/metadata.xml21
-rw-r--r--games-fps/unreal/unreal-226.ebuild85
3 files changed, 0 insertions, 109 deletions
diff --git a/games-fps/unreal/Manifest b/games-fps/unreal/Manifest
deleted file mode 100644
index 96ca800e4f95..000000000000
--- a/games-fps/unreal/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST IpDrv-436-Linux-08-20-02.zip 105435 BLAKE2B 3b0c960513f3bfdaa5394148978f1258b54cedec0722890fd1d89a81b7c809a9d837f6da0e147f1566ee253ed6fd0c7692d043e50ddd383d99245f7aec3df759 SHA512 5f10152b87cf702225fe50d213f3fbd4865cb2f190e0c2c87c996420c115e5f84de7748af635705b8a2ea789bfeaaab4b927364563a4b83f973dcb5af866ccd7
-DIST unreali-install.run 3800432 BLAKE2B eb359ed910b864cf2a5f73a96b888d621157a0e9dd3627cc6f0bbb02370a2362e5e417c5ca638642b883acf625b470dc3fcfbed95d640ab6598b630f9ba365e1 SHA512 3af4bc0a7f6f256899efe04b23a5c9944655130ef9868c9f0a73f71fe1bb492da71a6814a8d472c01c3fec13b9e978853a5c3f6960a8c1b4de53aa3020eda7f3
-DIST ut-install-436.run 6225010 BLAKE2B 107a4991db59e1ff800bf2a1e002f0e56f5415b14a936ced149ace57c5359f10b75d0c2506e5fe40dfb2ca28b068cf225b35dda5fae0af84864df4edb560e05a SHA512 cfdeb9f345daef4b81acadfa24d711477ba208dffd50716087d034df2dc1eb0ac5bb03570f4f1701b3c4d46b8f954e6d23dde36fc20dafdc114e68730a1fc932
diff --git a/games-fps/unreal/metadata.xml b/games-fps/unreal/metadata.xml
deleted file mode 100644
index 6a1fcf4b013c..000000000000
--- a/games-fps/unreal/metadata.xml
+++ /dev/null
@@ -1,21 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
-</maintainer>
-<longdescription>
-In Unreal, players take on the role of a criminal whose transfer ship
-has crashed on the mysterious planet Gryphon, where a peaceful race
-known as the Nali have been hunted and enslaved by bloodthirsty aliens
-called Skaarj. To dominate Gryphon and mine its precious Tarydium, the
-Skaarj command legions of other menacing species like the gigantic
-Titans, the bio-engineered Brutes and the pack-hunting Krall. Unreal
-combatants must survive in the midst of this inter-species warfare
-armed with an array of deadly weapons. Players will visit ancient Nali
-ruins, underground mines, cities in the sky, spacecraft wreckage and
-even the mysterious Skaarj Mothership in this deadly hunt in which
-every character is both predator and prey.
-</longdescription>
-</pkgmetadata>
diff --git a/games-fps/unreal/unreal-226.ebuild b/games-fps/unreal/unreal-226.ebuild
deleted file mode 100644
index 53f546ffcffc..000000000000
--- a/games-fps/unreal/unreal-226.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils unpacker cdrom games
-
-DESCRIPTION="Futuristic FPS (a hack that runs on top of Unreal Tournament)"
-HOMEPAGE="https://www.oldunreal.com/ https://icculus.org/~chunky/ut/unreal/"
-SRC_URI="https://www.icculus.org/%7Echunky/ut/unreal/unreali-install.run
- https://www.ut-files.com/Patches/ut-install-436.run
- https://www.ut-files.com/Patches/ipdrv-436-linux-08-20-02.zip -> IpDrv-436-Linux-08-20-02.zip"
-
-LICENSE="all-rights-reserved"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-IUSE="X opengl"
-RESTRICT="mirror bindist"
-
-DEPEND="sys-libs/lib-compat
- app-arch/unzip
-"
-RDEPEND="
- >=media-libs/libsdl-1.2.15-r5[abi_x86_32(-)]
- x11-libs/libX11[abi_x86_32(-)]
- x11-libs/libXau[abi_x86_32(-)]
- x11-libs/libXdmcp[abi_x86_32(-)]
- x11-libs/libXext[abi_x86_32(-)]
- opengl? ( virtual/opengl[abi_x86_32(-)] )
-"
-
-S=${WORKDIR}
-
-src_unpack() {
- export CDROM_NAME_1="Unreal CD"
- export CDROM_NAME_2="Unreal Tournament CD"
- cdrom_get_cds System/Unreal.ini System/UnrealTournament.ini
- unpack_makeself unreali-install.run
- mkdir ut
- cd ut
- unpack_makeself ut-install-436.run
- unpack IpDrv-436-Linux-08-20-02.zip
-}
-
-src_install() {
- local dir=${GAMES_PREFIX_OPT}/unreal
- dodir "${dir}"
-
- tar -zxf ut/data.tar.gz -C "${D}/${dir}"
- tar -zxf ut/OpenGL.ini.tar.gz -C "${D}/${dir}"
- tar -zxf System.tar.gz -C "${D}/${dir}"
- insinto "${dir}"/System
- doins ut/IpDrv.so
-
- cp -rf "${CDROM_ROOT}"/{Maps,Music,Sounds} "${D}/${dir}/"
- for f in "${D}/${dir}"/Maps/Dm*.unr ; do
- mv "${f}" "${f/Dm/DM-}"
- done
- dosym Maps "${dir}"/maps
-
- if has_version '<games-fps/unreal-tournament-451' \
- || has_version '<games-fps/unreal-tournament-goty-451' ; then
- CDROM_ROOT="${GAMES_PREFIX_OPT}/unreal-tournament"
- else
- cdrom_load_next_cd
- fi
- insinto "${dir}"/Textures
- doins "${CDROM_ROOT}"/Textures/*.utx
- insinto "${dir}"/Sounds
- doins "${CDROM_ROOT}"/Sounds/*.uax
- insinto "${dir}"/System
- doins "${CDROM_ROOT}"/System/*.u
- insinto "${dir}"/Music
- doins "${CDROM_ROOT}"/Music/*.umx
-
- insinto "${dir}"
- doins icon.* README*
-
- exeinto "${dir}"
- doexe bin/x86/unreal
-
- games_make_wrapper unreal ./unreal "${dir}" "${dir}"
-
- prepgamesdirs
-}