summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/c++robots/c++robots-0-r1.ebuild')
-rw-r--r--games-misc/c++robots/c++robots-0-r1.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/games-misc/c++robots/c++robots-0-r1.ebuild b/games-misc/c++robots/c++robots-0-r1.ebuild
index bb398f5ac30a..06fad1c7d3c5 100644
--- a/games-misc/c++robots/c++robots-0-r1.ebuild
+++ b/games-misc/c++robots/c++robots-0-r1.ebuild
@@ -1,30 +1,26 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="ongoing 'King of the Hill' (KotH) tournament"
HOMEPAGE="http://www.gamerz.net/c++robots/"
-SRC_URI="http://www.gamerz.net/c++robots/c++robots.tar.gz"
+SRC_URI="mirror://gentoo/${PN}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86"
-IUSE="static"
S=${WORKDIR}/${PN}
+PATCHES=( "${FILESDIR}"/${P}-fix-build-system.patch )
-PATCHES=(
- "${FILESDIR}/proper-coding.patch"
-)
-
-src_compile() {
- local myldflags="${LDFLAGS}"
- use static && myldflags="${myldflags} -static"
- emake CFLAGS="${CFLAGS}" LDFLAGS="${myldflags}"
+src_configure() {
+ tc-export CXX
}
src_install() {
dobin combat cylon target tracker
- dodoc README
+ einstalldocs
}