summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/xcruiser/xcruiser-0.30-r1.ebuild')
-rw-r--r--games-misc/xcruiser/xcruiser-0.30-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-misc/xcruiser/xcruiser-0.30-r1.ebuild b/games-misc/xcruiser/xcruiser-0.30-r1.ebuild
new file mode 100644
index 000000000000..c5f7a85927f4
--- /dev/null
+++ b/games-misc/xcruiser/xcruiser-0.30-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Fly about 3D-formed file system"
+HOMEPAGE="http://xcruiser.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+
+RDEPEND="x11-libs/libXaw"
+DEPEND="${RDEPEND}
+ app-text/rman
+ x11-misc/gccmakedep
+ x11-misc/imake"
+
+src_compile() {
+ xmkmf -a
+ emake CC=$(tc-getCC) CDEBUGFLAGS="${CFLAGS}" LOCAL_LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin xcruiser
+ dodoc CHANGES README README.jp TODO
+ newman xcruiser.man xcruiser.1
+}