summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/biniax2/biniax2-1.30.ebuild')
-rw-r--r--games-puzzle/biniax2/biniax2-1.30.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-puzzle/biniax2/biniax2-1.30.ebuild b/games-puzzle/biniax2/biniax2-1.30.ebuild
new file mode 100644
index 000000000000..c5bf7dcf47fb
--- /dev/null
+++ b/games-puzzle/biniax2/biniax2-1.30.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Logic game with arcade and tactics modes"
+HOMEPAGE="http://biniax.com/"
+SRC_URI="http://mordred.dir.bg/biniax/${P}-fullsrc.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mod]"
+RDEPEND="${DEPEND}"
+S=${WORKDIR}
+
+src_prepare() {
+ rm -f data/Thumbs.db
+ sed -i \
+ -e "s:data/:${GAMES_DATADIR}/${PN}/:" \
+ desktop/{gfx,snd}.c \
+ || die
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-dotfiles.patch
+}
+
+src_install() {
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/*
+ doicon "${FILESDIR}"/${PN}.xpm
+ make_desktop_entry ${PN} Biniax-2
+ prepgamesdirs
+}