summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/concentration/concentration-1.2-r1.ebuild')
-rw-r--r--games-puzzle/concentration/concentration-1.2-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-puzzle/concentration/concentration-1.2-r1.ebuild b/games-puzzle/concentration/concentration-1.2-r1.ebuild
new file mode 100644
index 000000000000..902176460f0c
--- /dev/null
+++ b/games-puzzle/concentration/concentration-1.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="The classic memory game with some new life"
+HOMEPAGE="https://packages.gentoo.org/package/games-puzzle/concentration"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-ttf"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_install() {
+ default
+ newicon pics/set1/19.png ${PN}.png
+ make_desktop_entry ${PN} Concentration
+ prepgamesdirs
+}