summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/gnome-klotski/gnome-klotski-3.14.2.ebuild')
-rw-r--r--games-puzzle/gnome-klotski/gnome-klotski-3.14.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-puzzle/gnome-klotski/gnome-klotski-3.14.2.ebuild b/games-puzzle/gnome-klotski/gnome-klotski-3.14.2.ebuild
new file mode 100644
index 000000000000..0cfac834bb49
--- /dev/null
+++ b/games-puzzle/gnome-klotski/gnome-klotski-3.14.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.22"
+
+inherit gnome-games vala
+
+DESCRIPTION="Slide blocks to solve the puzzle"
+HOMEPAGE="https://wiki.gnome.org/Apps/Klotski"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=gnome-base/librsvg-2.32.0
+ >=x11-libs/gtk+-3.10:3
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ app-text/yelp-tools
+ dev-util/appdata-tools
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome-games_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ gnome-games_src_configure APPDATA_VALIDATE=$(type -P true)
+}