summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/gottet')
-rw-r--r--games-puzzle/gottet/Manifest1
-rw-r--r--games-puzzle/gottet/files/gottet-1.0.6-gentoo.patch11
-rw-r--r--games-puzzle/gottet/gottet-1.0.6.ebuild50
-rw-r--r--games-puzzle/gottet/metadata.xml5
4 files changed, 67 insertions, 0 deletions
diff --git a/games-puzzle/gottet/Manifest b/games-puzzle/gottet/Manifest
new file mode 100644
index 000000000000..6afb7395e1e1
--- /dev/null
+++ b/games-puzzle/gottet/Manifest
@@ -0,0 +1 @@
+DIST gottet-1.0.6-src.tar.bz2 268854 SHA256 66338509e04927b76804cb0a3ebb31989a4c6f2500e8b99bec6d1db1121cd561 SHA512 20755d1bdd62259226dbe389a322bb8abf8608e0b08ee337e4a4b59e881ea176ccb5579fd4047ea994024b8db8bdb645b002ece00d7858dd235406c0505dee8e WHIRLPOOL f6c6ea0e49f50a05d46ef0c03da89563324ae4b68c4b6cebbdb5f4d9b2a24c4813e9f058135e6a33568fb95117f8765c507a4b01dff626a0b176bbbf8bfc3062
diff --git a/games-puzzle/gottet/files/gottet-1.0.6-gentoo.patch b/games-puzzle/gottet/files/gottet-1.0.6-gentoo.patch
new file mode 100644
index 000000000000..3b34dae0e261
--- /dev/null
+++ b/games-puzzle/gottet/files/gottet-1.0.6-gentoo.patch
@@ -0,0 +1,11 @@
+--- src/locale_dialog.cpp.old 2014-05-18 18:11:33.546814928 +0200
++++ src/locale_dialog.cpp 2014-05-18 18:40:56.033720946 +0200
+@@ -85,7 +85,7 @@
+ if (paths.isEmpty()) {
+ QString appdir = QCoreApplication::applicationDirPath();
+ paths.append(appdir);
+- paths.append(appdir + "/../share/" + QCoreApplication::applicationName().toLower());
++ paths.append("@GENTOO_DATADIR@/" + QCoreApplication::applicationName().toLower());
+ paths.append(appdir + "/../Resources");
+ }
+ foreach (const QString& path, paths) {
diff --git a/games-puzzle/gottet/gottet-1.0.6.ebuild b/games-puzzle/gottet/gottet-1.0.6.ebuild
new file mode 100644
index 000000000000..fcce03800750
--- /dev/null
+++ b/games-puzzle/gottet/gottet-1.0.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+LANGS="ca de en es fr he ko ms pl ro ru tr vi"
+inherit eutils qt4-r2 games
+
+DESCRIPTION="A tetris clone based on Qt4"
+HOMEPAGE="http://gottcode.org/gottet/"
+SRC_URI="http://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}:" \
+ src/locale_dialog.cpp \
+ || die "sed failed"
+}
+
+src_configure() {
+ qt4-r2_src_configure
+}
+
+src_install() {
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}/translations/
+ for lang in ${LINGUAS};do
+ for x in ${LANGS};do
+ if [[ ${lang} == ${x} ]];then
+ doins translations/${PN}_${x}.qm
+ fi
+ done
+ done
+ insinto /usr/share/icons
+ doins -r icons/hicolor
+ dodoc CREDITS ChangeLog NEWS README
+ doicon icons/${PN}.xpm
+ domenu icons/${PN}.desktop
+ prepgamesdirs
+}
diff --git a/games-puzzle/gottet/metadata.xml b/games-puzzle/gottet/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/gottet/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>