summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/world-of-goo-demo')
-rw-r--r--games-puzzle/world-of-goo-demo/Manifest1
-rw-r--r--games-puzzle/world-of-goo-demo/metadata.xml5
-rw-r--r--games-puzzle/world-of-goo-demo/world-of-goo-demo-1.41-r1.ebuild68
3 files changed, 74 insertions, 0 deletions
diff --git a/games-puzzle/world-of-goo-demo/Manifest b/games-puzzle/world-of-goo-demo/Manifest
new file mode 100644
index 000000000000..ac8939ff83c4
--- /dev/null
+++ b/games-puzzle/world-of-goo-demo/Manifest
@@ -0,0 +1 @@
+DIST WorldOfGooDemo.1.41.tar.gz 34729052 SHA256 3177b5561c843182613621a3b69800e431d9e1c8cc36fbf42192edc9428fac59 SHA512 5dcaf7cdacedf0df92133284c4781e1d4ad14abbeddd623a35e59129fc5c1cbb3782d570ac83bc6201f3212c15195e5ca637400839e87fe95edddc5ca671077a WHIRLPOOL 519c60c1715ec7a69c03381383ad30f5a73cc6b7de28d9b6e1a76f6119232fcd1dc46432b51cba285a3f7f1f0abc93bbd6029d2b8f9c5e14cf22bd27d613a238
diff --git a/games-puzzle/world-of-goo-demo/metadata.xml b/games-puzzle/world-of-goo-demo/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/world-of-goo-demo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-puzzle/world-of-goo-demo/world-of-goo-demo-1.41-r1.ebuild b/games-puzzle/world-of-goo-demo/world-of-goo-demo-1.41-r1.ebuild
new file mode 100644
index 000000000000..69aac993bdf8
--- /dev/null
+++ b/games-puzzle/world-of-goo-demo/world-of-goo-demo-1.41-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A puzzle game with a strong emphasis on physics"
+HOMEPAGE="http://2dboy.com/"
+
+if [[ ${PN} == *-demo ]] ; then
+ MY_PN="WorldOfGooDemo"
+ SRC_URI="${MY_PN}.${PV}.tar.gz"
+else
+ MY_PN="WorldOfGoo"
+ SRC_URI="${MY_PN}Setup.${PV}.tar.gz"
+fi
+
+LICENSE="2dboy-EULA"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RESTRICT="fetch strip"
+
+RDEPEND="media-libs/libsdl[sound,opengl,video]
+ media-libs/sdl-mixer[vorbis]
+ sys-libs/glibc
+ virtual/opengl
+ virtual/glu
+ >=sys-devel/gcc-3.4"
+DEPEND=""
+
+S=${WORKDIR}/${MY_PN}
+dir=${GAMES_PREFIX_OPT}/${PN}
+
+QA_PREBUILT="${dir:1}/${MY_PN%Demo}.bin32
+ ${dir:1}/${MY_PN%Demo}.bin64"
+
+pkg_nofetch() {
+ if [[ ${PN} == *-demo ]] ; then
+ elog "To download the demo, visit http://worldofgoo.com/dl2.php?lk=demo"
+ elog "and download ${A} and place it in ${DISTDIR}"
+ else
+ elog "Download ${A} from ${HOMEPAGE} and place it in ${DISTDIR}"
+ fi
+}
+
+src_install() {
+ exeinto "${dir}"
+ doexe ${MY_PN%Demo}*
+
+ games_make_wrapper ${PN} "${dir}"/${MY_PN%Demo}
+
+ insinto "${dir}"
+ doins -r icons properties res
+ newicon icons/scalable.svg ${PN}.svg
+
+ if [[ ${PN} == *-demo ]] ; then
+ make_desktop_entry ${PN} "World of Goo (Demo)"
+ else
+ make_desktop_entry ${PN} "World of Goo"
+ fi
+
+ dodoc linux-issues.txt
+ dohtml readme.html
+
+ prepgamesdirs
+}