summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/xblockout')
-rw-r--r--games-puzzle/xblockout/Manifest1
-rw-r--r--games-puzzle/xblockout/files/xblockout-1.1.6-font.patch46
-rw-r--r--games-puzzle/xblockout/metadata.xml5
-rw-r--r--games-puzzle/xblockout/xblockout-1.1.6.ebuild55
4 files changed, 107 insertions, 0 deletions
diff --git a/games-puzzle/xblockout/Manifest b/games-puzzle/xblockout/Manifest
new file mode 100644
index 000000000000..243c818f0c50
--- /dev/null
+++ b/games-puzzle/xblockout/Manifest
@@ -0,0 +1 @@
+DIST xbl-1.1.6.tar.gz 136504 SHA256 85f456b6aca15f1642bbd233872250918432f0b5252d4b0d681bc2394fda5f84 SHA512 96bf0460863698136a61b43260feed0e90e7ca5b6613d54c8ca98f51557a3d235597eeab46141cd6771aa0bf4fe019c5e4291dd826338e186cc905e3837531e0 WHIRLPOOL 94f3bd29f13d2e0774e491f0624b7b5d912e37c071fb9490d2b5a5320990731193cd78235aa49e860c2e7b976ced5223c5875a82baaaa846492154ebc5fe2a20
diff --git a/games-puzzle/xblockout/files/xblockout-1.1.6-font.patch b/games-puzzle/xblockout/files/xblockout-1.1.6-font.patch
new file mode 100644
index 000000000000..bb0302963bdc
--- /dev/null
+++ b/games-puzzle/xblockout/files/xblockout-1.1.6-font.patch
@@ -0,0 +1,46 @@
+--- initmenu.c.old 2008-10-27 23:23:43.000000000 +0100
++++ initmenu.c 2008-10-27 23:22:52.000000000 +0100
+@@ -408,19 +408,17 @@
+ XCharStruct overall_return ;
+
+ m->xfont = XLoadQueryFont( x->display , opt->thefont ) ;
+- m->font = XLoadFont( x->display , opt->thefont ) ;
+ if ( opt->verbose )
+ {
+ fprintf(stderr,"font=%s\n", opt->thefont) ;
+ }
+- if ( m->font==BadAlloc || m->font==BadName || m->xfont==0 )
++ if ( m->xfont==0 )
+ {
+ fprintf(stderr,"Some problems when loading a font... trying others\n") ;
+ m->xfont = XLoadQueryFont( x->display ,
+ "-*-*-*-*-*-*-*-*-*-*-*-*-*-*" ) ;
+- m->font = XLoadFont( x->display ,
+- "-*-*-*-*-*-*-*-*-*-*-*-*-*-*" ) ;
+- if ( m->font==BadAlloc || m->font==BadName || m->xfont==0 )
++ m->font = m->xfont->fid;
++ if ( m->xfont==0 )
+ {
+ fprintf(stderr,"You haven't -*-*-*-*-*-*-*-*-*-*-*-*-*-*\n");
+ fprintf(stderr,"Have you A font?\n");
+@@ -428,17 +426,17 @@
+ exit(1) ;
+ }
+ }
++ m->font = m->xfont->fid;
+ m->xfont2 = XLoadQueryFont( x->display , opt->thefont2 ) ;
+- m->font2 = XLoadFont( x->display , opt->thefont2 ) ;
+ if ( opt->verbose )
+ {
+ fprintf(stderr,"font2=%s\n", opt->thefont2) ;
+ }
+- if ( m->font2==BadAlloc || m->font2==BadName || m->xfont2==0 )
++ if ( m->xfont2==0 )
+ {
+- m->font2 = m->font ;
+ m->xfont2 = m->xfont ;
+ }
++ m->font2 = m->xfont2->fid;
+
+ xgc.background = x->back_pixel ;
+ xgc.foreground = opt->backcolor!=7 ? x->white_pixel : x->black_pixel;
diff --git a/games-puzzle/xblockout/metadata.xml b/games-puzzle/xblockout/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/xblockout/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-puzzle/xblockout/xblockout-1.1.6.ebuild b/games-puzzle/xblockout/xblockout-1.1.6.ebuild
new file mode 100644
index 000000000000..d1d71140ac69
--- /dev/null
+++ b/games-puzzle/xblockout/xblockout-1.1.6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools flag-o-matic eutils games
+
+DESCRIPTION="X Window block dropping game in 3 Dimension"
+HOMEPAGE="http://perso.univ-lyon1.fr/thierry.excoffier/XBL/"
+SRC_URI="http://perso.univ-lyon1.fr/thierry.excoffier/XBL/xbl-${PV}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/xbl-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-font.patch
+ sed -i \
+ -e '/^CC/d' \
+ -e 's:-lm:-lm -lX11:' \
+ -e '/DGROUP_GID/d' \
+ -e "s:-g$:${CFLAGS}:" \
+ Makefile.in || die
+ # Don't know about other archs. --slarti
+ use amd64 && filter-flags "-fweb"
+ eautoreconf
+}
+
+src_compile() {
+ emake \
+ USE_SETGID= \
+ SCOREDIR="${GAMES_DATADIR}/${PN}" \
+ RESOURCEDIR="${GAMES_DATADIR}/${PN}" \
+ LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ newgamesbin bl xbl
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ newins Xbl.ad Xbl
+
+ newman xbl.man xbl.6
+ dodoc README xbl-README
+ dohtml *.html *.gif
+ make_desktop_entry xbl XBlockOut
+ prepgamesdirs
+}