summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/skladnik/Manifest1
-rw-r--r--games-puzzle/skladnik/skladnik-24.05.0.ebuild33
-rw-r--r--games-puzzle/textmaze/textmaze-1.2-r2.ebuild (renamed from games-puzzle/textmaze/textmaze-1.2-r1.ebuild)17
-rw-r--r--games-puzzle/tong/tong-1.2-r2.ebuild (renamed from games-puzzle/tong/tong-1.2-r1.ebuild)24
-rw-r--r--games-puzzle/zaz/zaz-1.0.0-r2.ebuild (renamed from games-puzzle/zaz/zaz-1.0.0-r1.ebuild)2
5 files changed, 55 insertions, 22 deletions
diff --git a/games-puzzle/skladnik/Manifest b/games-puzzle/skladnik/Manifest
index 17f24bea30b4..f8a9df4c7781 100644
--- a/games-puzzle/skladnik/Manifest
+++ b/games-puzzle/skladnik/Manifest
@@ -1,2 +1,3 @@
DIST skladnik-0.5.1.tar.xz 397604 BLAKE2B 1d99e01a611c819d21a4ef009070a07c64e19499ddb54ce21611850092cc3a2e1877ab034b7b722fe962d641b00d3ac195e541966372cc8518d75a404051f3e6 SHA512 84a8494a679d228a41f559c4d986bf50c7ee287e9af3d400e9cc35347ce4ac72166ee1691bfb6739b9c1923c5d6e3d48c695592dbd12238f10a0977957ad09a6
DIST skladnik-0.5.2.tar.xz 404704 BLAKE2B 12f7746ea03f1b25ddc2b16071668a0966076129189c19a77b562b19961f54ca1b1c3df99d77adc068d1cd6b0b69e9b7be928cacee3ecdb244e7b5621a07012f SHA512 ced1f544bd5ffc383522b9a2655e890f229c6d94aa51386e937c4c101750e21a10179eaa5c62d2d08b5077423869f8eefcd2d5671c9f35c6e7c8759bbcfcde05
+DIST skladnik-24.05.0.tar.xz 408040 BLAKE2B 2fcbbe8088d7020328a94c8898e96c064871f2d893fcf0e1297c19e406976d845dd444778a85e2b2890a347e8dcca903936f3ca89147cbf2ac8f1e5462585954 SHA512 3710f185d007c5dbac83ec7aeb7def60fdcb35b2f976e5517ee0525933cf795b2b1d496ed94cda355921a3d653a6678613aa3fc16c6178ba184e6ba8b321839d
diff --git a/games-puzzle/skladnik/skladnik-24.05.0.ebuild b/games-puzzle/skladnik/skladnik-24.05.0.ebuild
new file mode 100644
index 000000000000..df3df346eebb
--- /dev/null
+++ b/games-puzzle/skladnik/skladnik-24.05.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="optional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.0.0
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="The Japanese warehouse keeper sokoban game"
+HOMEPAGE="https://apps.kde.org/skladnik/ https://invent.kde.org/games/skladnik"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui,widgets]
+ >=kde-apps/libkdegames-${PVCUT}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kcrash-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+"
+DEPEND="${RDEPEND}"
+BDEPEND="media-gfx/povray"
diff --git a/games-puzzle/textmaze/textmaze-1.2-r1.ebuild b/games-puzzle/textmaze/textmaze-1.2-r2.ebuild
index 4995efab9968..e73d6073a677 100644
--- a/games-puzzle/textmaze/textmaze-1.2-r1.ebuild
+++ b/games-puzzle/textmaze/textmaze-1.2-r2.ebuild
@@ -1,22 +1,19 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-MY_P=${PN}_v${PV}
-DESCRIPTION="An ncurses-based maze solving game written in Perl"
+MY_P="${PN}_v${PV}"
+DESCRIPTION="Ncurses-based maze solving game written in Perl"
HOMEPAGE="https://robobunny.com/projects/textmaze/html/"
-SRC_URI="https://www.robobunny.com/projects/${PN}/${MY_P}.tar.gz"
+SRC_URI="https://robobunny.com/projects/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/TextMaze"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RDEPEND="dev-perl/Curses"
-DEPEND=""
-
-S="${WORKDIR}/TextMaze"
src_prepare() {
default
diff --git a/games-puzzle/tong/tong-1.2-r1.ebuild b/games-puzzle/tong/tong-1.2-r2.ebuild
index a16067fc57ba..615c89826b27 100644
--- a/games-puzzle/tong/tong-1.2-r1.ebuild
+++ b/games-puzzle/tong/tong-1.2-r2.ebuild
@@ -1,31 +1,33 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit desktop
DESCRIPTION="Tetris and Pong in the same place at the same time"
-HOMEPAGE="http://www.nongnu.org/tong/"
-SRC_URI="http://www.nongnu.org/tong/${P}.tar.gz"
+HOMEPAGE="https://www.nongnu.org/tong/"
+SRC_URI="https://www.nongnu.org/tong/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
-LICENSE="GPL-2"
+LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
DEPEND="media-libs/libsdl[sound,joystick,video]
media-libs/sdl-image[png]
media-libs/sdl-mixer[vorbis]"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${PN}"
+PATCHES=(
+ "${FILESDIR}/${P}-makefile.patch"
+ "${FILESDIR}/${P}-fps.patch"
+ "${FILESDIR}/${P}-datadir.patch"
+)
src_prepare() {
default
- eapply \
- "${FILESDIR}/${P}-makefile.patch" \
- "${FILESDIR}/${P}-fps.patch" \
- "${FILESDIR}/${P}-datadir.patch"
+
sed -i \
-e "s:\"media/:\"/usr/share/${PN}/media/:" \
media.cpp option.cpp option.h pong.cpp tetris.cpp text.cpp \
diff --git a/games-puzzle/zaz/zaz-1.0.0-r1.ebuild b/games-puzzle/zaz/zaz-1.0.0-r2.ebuild
index 0cc5f0820283..d029a94a7a34 100644
--- a/games-puzzle/zaz/zaz-1.0.0-r1.ebuild
+++ b/games-puzzle/zaz/zaz-1.0.0-r2.ebuild
@@ -9,7 +9,7 @@ DESCRIPTION="A puzzle game where the player has to arrange balls in triplets"
HOMEPAGE="https://sourceforge.net/projects/zaz/"
SRC_URI="https://downloads.sourceforge.net/zaz/${P}.tar.bz2"
-LICENSE="GPL-3 GPL-3+ CC-BY-SA-3.0 OFL"
+LICENSE="GPL-3 GPL-3+ CC-BY-SA-3.0 OFL-1.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="nls"