summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/hexalate/Manifest1
-rw-r--r--games-puzzle/hexalate/hexalate-1.1.3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/games-puzzle/hexalate/Manifest b/games-puzzle/hexalate/Manifest
index 3350597ef6eb..22b7fd716acf 100644
--- a/games-puzzle/hexalate/Manifest
+++ b/games-puzzle/hexalate/Manifest
@@ -1 +1,2 @@
DIST hexalate-1.1.0-src.tar.bz2 662438 BLAKE2B 6902b27db72224e684ff4e98fcc0b8810ab5984bf85c894601035592a478716e9959860af593e977d349ab1f9514f1b7ed4851e7c0c06addbb05c3805344f31d SHA512 2f8775c9cb85ff78fb84109f78079013fa172a6b37b309e1cac033be4eb1c248a005a2e899eb785fbe1f89fd87a2035dae3e7016a26af6f3e82a7174dc010a64
+DIST hexalate-1.1.3-src.tar.bz2 798580 BLAKE2B 685a5fb106b9e4e33d63651059bc63b155c4b1afc1426506f8535b93c54bda1cbf8705244790fe130fe92e82bb6b7d9710c3aa8f245f0d578ddf09fa1e51551d SHA512 037dec9bb7b9dbc3cf3659e765c6e333dbbd0a94426e0b79c20695cf402cffb141c28c9ece4405281617dace7510b982180475c129648a871036be226e868bd6
diff --git a/games-puzzle/hexalate/hexalate-1.1.3.ebuild b/games-puzzle/hexalate/hexalate-1.1.3.ebuild
new file mode 100644
index 000000000000..23dec27a0760
--- /dev/null
+++ b/games-puzzle/hexalate/hexalate-1.1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils qmake-utils
+
+DESCRIPTION="A color matching game"
+HOMEPAGE="https://gottcode.org/hexalate/"
+SRC_URI="https://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+src_configure() {
+ eqmake5 PREFIX="/usr"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}