summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/lpairs/lpairs-1.0.4.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/games-puzzle/lpairs/lpairs-1.0.4.ebuild b/games-puzzle/lpairs/lpairs-1.0.4.ebuild
index 6d08273de8df..9f3a03828237 100644
--- a/games-puzzle/lpairs/lpairs-1.0.4.ebuild
+++ b/games-puzzle/lpairs/lpairs-1.0.4.ebuild
@@ -9,12 +9,12 @@ DESCRIPTION="A classical memory game"
HOMEPAGE="http://lgames.sourceforge.net/index.php?project=LPairs"
SRC_URI="mirror://sourceforge/lgames/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE="nls"
+IUSE="nls sound"
-RDEPEND="media-libs/libsdl
+RDEPEND="media-libs/libsdl[sound?,video]
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
@@ -23,14 +23,16 @@ src_prepare() {
sed -i \
-e 's:$localedir:/usr/share/locale:' \
-e 's:$(localedir):/usr/share/locale:' \
- configure po/Makefile.in.in \
- || die "sed failed"
+ configure po/Makefile.in.in || die
+ # gcc5 doesn't like the way inline is used. just punt it. (bug #568684)
+ sed -i -e 's/^inline//g' lpairs/{sdl.[ch],pairs.[ch]} || die
}
src_configure() {
egamesconf \
--datadir="${GAMES_DATADIR_BASE}" \
- $(use_enable nls)
+ $(use_enable nls) \
+ $(usex sound '' --disable-sound)
}
src_install() {