summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/crrcsim')
-rw-r--r--games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild52
-rw-r--r--games-simulation/crrcsim/crrcsim-0.9.13.ebuild62
-rw-r--r--games-simulation/crrcsim/files/crrcsim-0.9.13-buildsystem.patch62
-rw-r--r--games-simulation/crrcsim/files/crrcsim-0.9.13-clang.patch10
-rw-r--r--games-simulation/crrcsim/files/crrcsim-0.9.13-overlink.patch20
-rw-r--r--games-simulation/crrcsim/files/crrcsim-cgal_gmp.patch11
-rw-r--r--games-simulation/crrcsim/metadata.xml2
7 files changed, 83 insertions, 136 deletions
diff --git a/games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild b/games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild
new file mode 100644
index 000000000000..3acdebc8c4e8
--- /dev/null
+++ b/games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools desktop
+
+DESCRIPTION="Model-airplane flight simulation program"
+HOMEPAGE="https://sourceforge.net/projects/crrcsim/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="portaudio"
+
+RDEPEND="
+ dev-libs/gmp:=
+ media-libs/libsdl[X,sound,joystick,opengl,video]
+ media-libs/plib
+ virtual/glu
+ virtual/jpeg
+ virtual/opengl
+ portaudio? ( media-libs/portaudio )"
+DEPEND="
+ ${RDEPEND}
+ sci-mathematics/cgal"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc6.patch
+ "${FILESDIR}"/${P}-overlink.patch
+ "${FILESDIR}"/${P}-clang.patch
+)
+
+DOCS=( AUTHORS HISTORY )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf ac_cv_header_portaudio_h=$(usex portaudio)
+}
+
+src_install() {
+ default
+
+ doicon packages/icons/${PN}.png
+ make_desktop_entry ${PN} CRRCSim
+}
diff --git a/games-simulation/crrcsim/crrcsim-0.9.13.ebuild b/games-simulation/crrcsim/crrcsim-0.9.13.ebuild
deleted file mode 100644
index ef5b5ce752df..000000000000
--- a/games-simulation/crrcsim/crrcsim-0.9.13.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-WANT_AUTOMAKE="1.10"
-inherit autotools eutils gnome2-utils
-
-DESCRIPTION="model-airplane flight simulation program"
-HOMEPAGE="https://sourceforge.net/projects/crrcsim/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="portaudio"
-
-RDEPEND="media-libs/libsdl[X,sound,joystick,opengl,video]
- media-libs/plib
- sci-mathematics/cgal
- portaudio? ( media-libs/portaudio )"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-buildsystem.patch
- "${FILESDIR}"/${P}-gcc6.patch
-)
-
-src_prepare() {
- default
-
- if has_version "sci-mathematics/cgal[gmp(+)]" ; then
- eapply "${FILESDIR}"/${PN}-cgal_gmp.patch
- fi
- eautoreconf
-}
-
-src_configure() {
- econf \
- --datadir="/usr/share" \
- --datarootdir="${EPREFIX%/}/usr/share" \
- --docdir="${EPREFIX%/}/usr/share/doc/${PF}" \
- $(use_with portaudio)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS HISTORY NEWS README
- doicon -s 32 packages/icons/${PN}.png
- make_desktop_entry ${PN}
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}
diff --git a/games-simulation/crrcsim/files/crrcsim-0.9.13-buildsystem.patch b/games-simulation/crrcsim/files/crrcsim-0.9.13-buildsystem.patch
deleted file mode 100644
index 396fd573ec90..000000000000
--- a/games-simulation/crrcsim/files/crrcsim-0.9.13-buildsystem.patch
+++ /dev/null
@@ -1,62 +0,0 @@
---- crrcsim-0.9.11/configure.ac
-+++ crrcsim-0.9.11/configure.ac
-@@ -79,8 +79,12 @@
- dnl Default is: no portaudio present
- portaudio=0
-
-+AC_ARG_WITH([portaudio], AS_HELP_STRING([--without-portaudio], [Build without portaudio library (default: test)]))
-+
-+AS_IF([test "x$with_portaudio" != "xno"], [
- dnl Check for the Portaudio header file
- AC_CHECK_HEADER([portaudio.h])
-+])
-
- if (test "x$ac_cv_header_portaudio_h" = "xyes"); then
- dnl Check for Portaudio 18
---- crrcsim-0.9.13/src/mod_misc/filesystools.cpp
-+++ crrcsim-0.9.13/src/mod_misc/filesystools.cpp
-@@ -113,8 +113,8 @@
- // $USERPROFILE/.crrcsim (WIN32)
- // $HOME/.crrcsim (LINUX)
- // CRRC_DATA_PATH (LINUX)
-- // /usr/local/share/games/crrcsim (LINUX)
-- // /usr/share/games/crrcsim (LINUX)
-+ // /usr/local/share/crrcsim (LINUX)
-+ // /usr/share/crrcsim (LINUX)
-
- // cwd
- if (dirname != "")
-@@ -154,13 +154,13 @@
- s.append(dirname);
- pathlist.push_back(s);
- #endif
-- s = "/usr/local/share/games/" + appname + "/";
-+ s = "/usr/local/share/" + appname + "/";
- if (s != data_path) // avoid adding this path twice
- {
- s.append(dirname);
- pathlist.push_back(s);
- }
-- s = "/usr/share/games/" + appname + "/";
-+ s = "/usr/share/" + appname + "/";
- if (s != data_path) // avoid adding this path twice
- {
- s.append(dirname);
-@@ -172,13 +172,13 @@
- #ifdef CRRC_DATA_PATH
- pathlist.push_back(data_path);
- #endif
-- if (data_path != "/usr/local/share/games/" + appname) // avoid adding this path twice
-+ if (data_path != "/usr/local/share/" + appname) // avoid adding this path twice
- {
-- pathlist.push_back("/usr/local/share/games/" + appname);
-+ pathlist.push_back("/usr/local/share/" + appname);
- }
-- if (data_path != "/usr/share/games/" + appname) // avoid adding this path twice
-+ if (data_path != "/usr/share/" + appname) // avoid adding this path twice
- {
-- pathlist.push_back("/usr/share/games/" + appname);
-+ pathlist.push_back("/usr/share/" + appname);
- }
- }
- #endif
diff --git a/games-simulation/crrcsim/files/crrcsim-0.9.13-clang.patch b/games-simulation/crrcsim/files/crrcsim-0.9.13-clang.patch
new file mode 100644
index 000000000000..967d51d7239d
--- /dev/null
+++ b/games-simulation/crrcsim/files/crrcsim-0.9.13-clang.patch
@@ -0,0 +1,10 @@
+https://bugs.gentoo.org/830572
+--- a/src/mod_fdm_config.h
++++ b/src/mod_fdm_config.h
+@@ -36,5 +36,5 @@
+ #define MOD_FDM_USE_MCOPTER01 1
+
+-#define MOD_FDM_INFOSTR "CRRCSim "PACKAGE_VERSION
++#define MOD_FDM_INFOSTR "CRRCSim " PACKAGE_VERSION
+
+
diff --git a/games-simulation/crrcsim/files/crrcsim-0.9.13-overlink.patch b/games-simulation/crrcsim/files/crrcsim-0.9.13-overlink.patch
new file mode 100644
index 000000000000..42bcc6e3d995
--- /dev/null
+++ b/games-simulation/crrcsim/files/crrcsim-0.9.13-overlink.patch
@@ -0,0 +1,20 @@
+With CGAL now being header-only and boost-1.77.0 dropping thread-mt (not
+actually linking with it), these link attempts just cause unnecessary issues.
+
+https://bugs.gentoo.org/790779
+https://bugs.gentoo.org/808727
+--- a/configure.ac
++++ b/configure.ac
+@@ -227,5 +227,4 @@
+ has_CGAL="yes (found CGAL > v3)"
+ AC_CHECK_LIB(gmp,__gmpq_init,,AC_MSG_ERROR([gmp library not found. Please install it.]))
+- AC_CHECK_LIB(boost_thread-mt,main,,AC_MSG_ERROR([boost_thread-mt library not found. Please install it.]))
+ else
+ AC_DEFINE([CGAL_VERSION3], [1], [CGAL_VERSION3 compatibility])
+@@ -233,5 +232,5 @@
+ fi
+ CGAL_CFLAGS=-frounding-math
+- CGAL_LIBS=-lCGAL
++ CGAL_LIBS=
+ AC_DEFINE([WINDDATA3D], [1], [Import code for wind data, needs CGAL, 0 to disable])
+ else
diff --git a/games-simulation/crrcsim/files/crrcsim-cgal_gmp.patch b/games-simulation/crrcsim/files/crrcsim-cgal_gmp.patch
deleted file mode 100644
index 10d6bff6b769..000000000000
--- a/games-simulation/crrcsim/files/crrcsim-cgal_gmp.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- crrcsim-0.9.11/configure.ac
-+++ crrcsim-0.9.11/configure.ac
-@@ -229,7 +229,7 @@
- has_CGAL="yes (found CGAL v3)"
- fi
- CGAL_CFLAGS=-frounding-math
-- CGAL_LIBS=-lCGAL
-+ CGAL_LIBS="-lCGAL -lgmp"
- AC_DEFINE([WINDDATA3D], [1], [Import code for wind data, needs CGAL, 0 to disable])
- else
- has_CGAL="no (CGAL not found)"
diff --git a/games-simulation/crrcsim/metadata.xml b/games-simulation/crrcsim/metadata.xml
index 99cf739c786a..6f4d5c366b9c 100644
--- a/games-simulation/crrcsim/metadata.xml
+++ b/games-simulation/crrcsim/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>games@gentoo.org</email>