summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-sports/bygfoot/bygfoot-2.3.2-r1.ebuild')
-rw-r--r--games-sports/bygfoot/bygfoot-2.3.2-r1.ebuild27
1 files changed, 12 insertions, 15 deletions
diff --git a/games-sports/bygfoot/bygfoot-2.3.2-r1.ebuild b/games-sports/bygfoot/bygfoot-2.3.2-r1.ebuild
index 9ed990aea67c..6a48c7824293 100644
--- a/games-sports/bygfoot/bygfoot-2.3.2-r1.ebuild
+++ b/games-sports/bygfoot/bygfoot-2.3.2-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils vcs-clean
+inherit desktop vcs-clean
DESCRIPTION="GTK+2 Soccer Management Game"
HOMEPAGE="http://bygfoot.sourceforge.net/"
@@ -12,35 +12,32 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RDEPEND="
app-arch/zip
media-libs/freetype:2
x11-libs/gtk+:2
virtual/libintl"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
sys-devel/gettext
virtual/pkgconfig"
-src_prepare() {
- default
-
- sed -i \
- -e 's:$(gnulocaledir):/usr/share/locale:' \
- -e '/PACKAGE_LOCALE_DIR/s:\$(prefix)/\$(DATADIRNAME):/usr/share:' \
- -e '/bygfoot_LDADD/s/$/ -lm/' \
- po/Makefile.in.in src/Makefile.in || die
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-Makefile.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
src_configure() {
econf --disable-gstreamer
}
src_install() {
- emake DESTDIR="${D}" install
+ default
+ dodoc UPDATE
+
esvn_clean "${D}"
- dodoc AUTHORS ChangeLog README TODO UPDATE
+
newicon support_files/pixmaps/bygfoot_icon.png ${PN}.png
make_desktop_entry ${PN} Bygfoot
}