summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/mindrover-demo')
-rw-r--r--games-strategy/mindrover-demo/Manifest1
-rw-r--r--games-strategy/mindrover-demo/metadata.xml5
-rw-r--r--games-strategy/mindrover-demo/mindrover-demo-1.07b.ebuild44
3 files changed, 50 insertions, 0 deletions
diff --git a/games-strategy/mindrover-demo/Manifest b/games-strategy/mindrover-demo/Manifest
new file mode 100644
index 000000000000..fa62ff5189d9
--- /dev/null
+++ b/games-strategy/mindrover-demo/Manifest
@@ -0,0 +1 @@
+DIST mindrover_demo.run 25266633 SHA256 049a70cb220e6a2cc5fcd4b1175d7cfb1727e960c9d300b5dfedd3755603e44a SHA512 ddb78f6a40bd42dd3b3ce0a6793f5e217937d3be1dd294d7d8596f8409eee506522a64d9396db2d93fa3beca197d85c7a6507a8f2ae773d0b9b123e9be1e761c WHIRLPOOL b3f5c684fed28cbfc1d0b815c8e2051b792384d9fbd22428b206b20029d8bd5e903d25a4466ebc545df94a7bc25e770648819caab3c61f22360878d733e46c98
diff --git a/games-strategy/mindrover-demo/metadata.xml b/games-strategy/mindrover-demo/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-strategy/mindrover-demo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-strategy/mindrover-demo/mindrover-demo-1.07b.ebuild b/games-strategy/mindrover-demo/mindrover-demo-1.07b.ebuild
new file mode 100644
index 000000000000..6caca7feb1be
--- /dev/null
+++ b/games-strategy/mindrover-demo/mindrover-demo-1.07b.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils unpacker games
+
+MY_P="mindrover_demo.run"
+DESCRIPTION="Control a robot as it races across Europa"
+HOMEPAGE="http://www.linuxgamepublishing.com/info.php?id=9"
+SRC_URI=" http://demos.linuxgamepublishing.com/mindrover/${MY_P}"
+
+LICENSE="all-rights-reserved GPL-2+"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+RESTRICT="mirror bindist strip"
+
+RDEPEND="virtual/opengl"
+
+S=${WORKDIR}
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+src_install() {
+ einfo "This will take a while ... go get a pizza or something"
+
+ dodir "${dir}"
+
+ tar -zxf data.tar.gz -C "${Ddir}"/ || die
+ tar -zxf music.tar.gz -C "${Ddir}"/ || die
+
+ dodoc README
+ newicon icon.xpm ${PN}.xpm || die
+ exeinto "${dir}"
+ doexe bin/Linux/x86/glibc-2.1/mindrover_demo \
+ bin/Linux/x86/glibc-2.1/lib/libopenal.so.0.0.6 || die
+ dosym "${dir}"/libopenal.so.0.0.6 "${dir}"/libopenal.so.0
+
+ games_make_wrapper ${PN} ./mindrover_demo "${dir}" "${dir}"
+ make_desktop_entry ${PN} "Mindrover: Europa Project (Demo)"
+
+ prepgamesdirs
+}