summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/tornado/tornado-1.4-r1.ebuild')
-rw-r--r--games-strategy/tornado/tornado-1.4-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/games-strategy/tornado/tornado-1.4-r1.ebuild b/games-strategy/tornado/tornado-1.4-r1.ebuild
new file mode 100644
index 000000000000..881a6f3ce85d
--- /dev/null
+++ b/games-strategy/tornado/tornado-1.4-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Clone of a C64 game - destroy the opponent's house"
+HOMEPAGE="https://github.com/kouya/tornado"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PF}-gentoo.patch
+)
+
+src_prepare() {
+ default
+
+ tc-export CC PKG_CONFIG
+}
+
+src_install() {
+ default
+ fperms 664 "/var/games/tornado.scores"
+}