summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/wesnoth/wesnoth-1.14.7.ebuild')
-rw-r--r--games-strategy/wesnoth/wesnoth-1.14.7.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/games-strategy/wesnoth/wesnoth-1.14.7.ebuild b/games-strategy/wesnoth/wesnoth-1.14.7.ebuild
index 510a59e68be9..06ff63ec4324 100644
--- a/games-strategy/wesnoth/wesnoth-1.14.7.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.14.7.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils user
+
+inherit cmake user
DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
HOMEPAGE="http://www.wesnoth.org
@@ -55,7 +56,7 @@ pkg_setup() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
if ! use doc ; then
sed -i \
@@ -106,14 +107,13 @@ src_configure() {
-DENABLE_FRIBIDI="$(usex fribidi)"
-DENABLE_OMP="$(usex openmp)"
-DENABLE_STRICT_COMPILATION="OFF"
- -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
local DOCS=( README.md changelog.md )
- cmake-utils_src_install
+ cmake_src_install
if use dedicated || use server; then
rmdir "${ED}/run/wesnothd" || die
newinitd "${FILESDIR}"/wesnothd.rc-r1 wesnothd