summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/deutex/deutex-5.2.0.ebuild')
-rw-r--r--games-util/deutex/deutex-5.2.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/games-util/deutex/deutex-5.2.0.ebuild b/games-util/deutex/deutex-5.2.0.ebuild
new file mode 100644
index 000000000000..f4802fcadd48
--- /dev/null
+++ b/games-util/deutex/deutex-5.2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="WAD composer for Doom, Heretic, Hexen, and Strife"
+HOMEPAGE="https://github.com/Doom-Utils/deutex"
+SRC_URI="https://github.com/Doom-Utils/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+ LGPL-2+ HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="man png"
+
+DEPEND="png? ( media-libs/libpng:0= )"
+RDEPEND="${DEPEND}"
+BDEPEND="man? ( app-text/asciidoc )"
+
+src_configure() {
+ econf \
+ $(use_enable man) \
+ $(use_with png libpng)
+}