summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/wxchtdecoder')
-rw-r--r--games-util/wxchtdecoder/wxchtdecoder-1.5a-r1.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/games-util/wxchtdecoder/wxchtdecoder-1.5a-r1.ebuild b/games-util/wxchtdecoder/wxchtdecoder-1.5a-r1.ebuild
index 0a8fbabae6b4..8e868e7bee79 100644
--- a/games-util/wxchtdecoder/wxchtdecoder-1.5a-r1.ebuild
+++ b/games-util/wxchtdecoder/wxchtdecoder-1.5a-r1.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
WX_GTK_VER="3.0"
-inherit eutils wxwidgets
+inherit wxwidgets
DESCRIPTION="A program to decode .CHT files in Snes9x and ZSNES to plain text"
HOMEPAGE="http://games.technoplaza.net/chtdecoder/"
@@ -12,17 +13,15 @@ SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="x11-libs/wxGTK:${WX_GTK_VER}[X]"
-RDEPEND=${DEPEND}
+RDEPEND="x11-libs/wxGTK:${WX_GTK_VER}[X]"
+DEPEND=${RDEPEND}
-src_prepare() {
- epatch "${FILESDIR}"/${P}-wxgtk.patch
-}
+PATCHES=( "${FILESDIR}"/${P}-wxgtk.patch )
src_configure() {
- econf --with-wx-config=${WX_CONFIG}
+ setup-wxwidgets
+ econf --with-wx-config="${WX_CONFIG}"
}
src_install() {