summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/chrome-gnome-shell/chrome-gnome-shell-6.ebuild')
-rw-r--r--gnome-extra/chrome-gnome-shell/chrome-gnome-shell-6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnome-extra/chrome-gnome-shell/chrome-gnome-shell-6.ebuild b/gnome-extra/chrome-gnome-shell/chrome-gnome-shell-6.ebuild
new file mode 100644
index 000000000000..de43d4aae568
--- /dev/null
+++ b/gnome-extra/chrome-gnome-shell/chrome-gnome-shell-6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="Provides integration with GNOME Shell extensions repository for Chrome browser"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShellIntegrationForChrome"
+SRC_URI="mirror://gnome/sources/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ gnome-base/gnome-shell
+"
+
+src_configure() {
+ python_fix_shebang ./connector
+
+ local mycmakeargs=( -DBUILD_EXTENSION=OFF )
+ cmake-utils_src_configure
+}