summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/gnome-system-monitor/gnome-system-monitor-3.28.2.ebuild')
-rw-r--r--gnome-extra/gnome-system-monitor/gnome-system-monitor-3.28.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.28.2.ebuild b/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.28.2.ebuild
new file mode 100644
index 000000000000..87e551af3204
--- /dev/null
+++ b/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.28.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="The Gnome System Monitor"
+HOMEPAGE="https://help.gnome.org/users/gnome-system-monitor/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="systemd X"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ >=dev-libs/glib-2.55.0:2
+ >=gnome-base/libgtop-2.37.2:2=
+ >=x11-libs/gtk+-3.22:3[X(+)]
+ >=dev-cpp/gtkmm-3.3.18:3.0
+ >=dev-cpp/glibmm-2.46:2
+ >=dev-libs/libxml2-2.0:2
+ >=gnome-base/librsvg-2.35:2
+ systemd? ( >=sys-apps/systemd-44:0= )
+ X? ( >=x11-libs/libwnck-2.91.0:3 )
+"
+# eautoreconf requires gnome-base/gnome-common
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ >=sys-auth/polkit-0.114
+" # polkit needed at buildtime for ITS rules of policy files, first available in 0.114
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable systemd) \
+ $(use_enable X broken-wnck) \
+ APPDATA_VALIDATE="$(type -P true)"
+}