summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/akonadi-contacts/akonadi-contacts-17.08.2.ebuild')
-rw-r--r--kde-apps/akonadi-contacts/akonadi-contacts-17.08.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/kde-apps/akonadi-contacts/akonadi-contacts-17.08.2.ebuild b/kde-apps/akonadi-contacts/akonadi-contacts-17.08.2.ebuild
new file mode 100644
index 000000000000..e791fd188c74
--- /dev/null
+++ b/kde-apps/akonadi-contacts/akonadi-contacts-17.08.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Library for akonadi contact integration"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+IUSE=""
+
+# some akonadi tests time out, that probably needs more work as it's ~700 tests
+RESTRICT+=" test"
+
+DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep prison)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-mime)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kmime)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ >=dev-libs/grantlee-5.1.0:5
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+"