summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/akonadi')
-rw-r--r--kde-apps/akonadi/Manifest1
-rw-r--r--kde-apps/akonadi/akonadi-17.04.1.ebuild121
2 files changed, 0 insertions, 122 deletions
diff --git a/kde-apps/akonadi/Manifest b/kde-apps/akonadi/Manifest
index f79996aff60f..c06f7374a5b8 100644
--- a/kde-apps/akonadi/Manifest
+++ b/kde-apps/akonadi/Manifest
@@ -1,3 +1,2 @@
DIST akonadi-1.13.1_pre20160203.tar.gz 384556 SHA256 4243b32e529be6aadc38dc4463cb6e7cede9442c05cfc04ba679dde28f37aa96 SHA512 0ef8213f504ad1e500a2c1ce19a7575cd1fd8b7ffc7e5fb0bd2437639d8c458c47bbfea7734fcd3e200136a661331dde32af0b064f0b25d324138ce6e35d15f3 WHIRLPOOL 69eff1889a19f8d5714d7e71a106871172cd25c651ea30046ab81270cf7e46c7a1983cf20fd8d5fd8ad243d70e881be705d57b0b93b54248d086e7b253a4873a
-DIST akonadi-17.04.1.tar.xz 1301584 SHA256 d247dbdc433e2d589191659c40e85bf7b9c51d6b6a4f8259cea3f13c005b5d37 SHA512 757dbea2eb9afde3ccae7a3ca4ae6b61e2881083ef9777e857e9534258fadb2c9e2ecd796ffb25f532457e9bc9ba87ede7692b1f94072d7ae19709b7c7b50d34 WHIRLPOOL 9823b4b972c5065d82ccaa3be47a13f88db10ee490780b2998f1fb75567eb5d72cfae843a211c3eea28776eaa4d9ce91b6412d0e22d68998a0e3f32eb77ec5ba
DIST akonadi-17.04.2.tar.xz 1302756 SHA256 cd10074e2791e80dd01b51e79ab033bfe552e2d82ed034d8d0c30fe7b2ef6321 SHA512 43d219db0b53a6cd90003007a507433660db4c86895ee2732d9494375205bef15f01a41b2aa3de658f911b6ae4434d25b1e8fe1c0adbdc72a25ef053404b5b55 WHIRLPOOL c5b9a371ab39de01bc5ce2193b7aed820431f931771f9f191a7889c9d9038d69e2815d870a3b6cd3da103083b228ba0aee156a1db7d38e00a5baf59a9f5d09fd
diff --git a/kde-apps/akonadi/akonadi-17.04.1.ebuild b/kde-apps/akonadi/akonadi-17.04.1.ebuild
deleted file mode 100644
index dc62c98e3b9e..000000000000
--- a/kde-apps/akonadi/akonadi-17.04.1.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-KDE_DESIGNERPLUGIN="true"
-KDE_TEST="forceoptional"
-VIRTUALDBUS_TEST="true"
-VIRTUALX_REQUIRED="test"
-inherit kde5
-
-DESCRIPTION="Storage service for PIM data and libraries for PIM apps"
-HOMEPAGE="https://pim.kde.org/akonadi"
-KEYWORDS="~amd64 ~arm ~x86"
-LICENSE="LGPL-2.1+"
-IUSE="+mysql postgres sqlite tools xml"
-
-REQUIRED_USE="|| ( sqlite mysql postgres ) test? ( tools )"
-
-# drop qtgui subslot operator when QT_MINIMAL >= 5.7.0
-COMMON_DEPEND="
- $(add_frameworks_dep kcompletion)
- $(add_frameworks_dep kconfig)
- $(add_frameworks_dep kconfigwidgets)
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep kcrash)
- $(add_frameworks_dep kdbusaddons)
- $(add_frameworks_dep ki18n)
- $(add_frameworks_dep kiconthemes)
- $(add_frameworks_dep kio)
- $(add_frameworks_dep kitemmodels)
- $(add_frameworks_dep kitemviews)
- $(add_frameworks_dep kwidgetsaddons)
- $(add_frameworks_dep kwindowsystem)
- $(add_frameworks_dep kxmlgui)
- $(add_qt_dep qtdbus)
- $(add_qt_dep qtgui '' '' '5=')
- $(add_qt_dep qtnetwork)
- $(add_qt_dep qtsql 'mysql?,postgres?')
- $(add_qt_dep qtwidgets)
- $(add_qt_dep qtxml)
- x11-misc/shared-mime-info
- sqlite? ( dev-db/sqlite:3 )
- xml? ( dev-libs/libxml2 )
-"
-DEPEND="${COMMON_DEPEND}
- dev-libs/boost
- dev-libs/libxslt
- test? ( sys-apps/dbus )
-"
-RDEPEND="${COMMON_DEPEND}
- !kde-apps/kdepim-l10n
- !kde-apps/kdepimlibs
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql )
-"
-
-# some akonadi tests time out, that probably needs more work as it's ~700 tests
-RESTRICT+=" test"
-
-PATCHES=( "${FILESDIR}/${PN}-17.03.80-mysql56-crash.patch" )
-
-pkg_setup() {
- # Set default storage backend in order: MySQL, SQLite PostgreSQL
- # reverse driver check to keep the order
- if use postgres; then
- DRIVER="QPSQL"
- AVAILABLE+=" ${DRIVER}"
- fi
-
- if use sqlite; then
- DRIVER="QSQLITE3"
- AVAILABLE+=" ${DRIVER}"
- fi
-
- if use mysql; then
- DRIVER="QMYSQL"
- AVAILABLE+=" ${DRIVER}"
- fi
-
- # Notify about MySQL is recommend by upstream
- if use sqlite || has_version "<${CATEGORY}/${P}[sqlite]"; then
- ewarn
- ewarn "We strongly recommend you change your Akonadi database backend to MySQL in your"
- ewarn "user configuration. This is the backend recommended by KDE upstream."
- ewarn "In particular, kde-apps/kmail-4.10 does not work properly with the sqlite"
- ewarn "backend anymore."
- ewarn "You can select the backend in your ~/.config/akonadi/akonadiserverrc."
- ewarn "Available drivers are:${AVAILABLE}"
- ewarn
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- -DAKONADI_BUILD_QSQLITE=$(usex sqlite)
- -DBUILD_TOOLS=$(usex tools)
- $(cmake-utils_use_find_package xml LibXml2)
- -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
- )
-
- kde5_src_configure
-}
-
-src_install() {
- # Who knows, maybe it accidentally fixes our permission issues
- cat <<-EOF > "${T}"/akonadiserverrc
-[%General]
-Driver=${DRIVER}
-EOF
- insinto /usr/share/config/akonadi
- doins "${T}"/akonadiserverrc
-
- kde5_src_install
-}
-
-pkg_postinst() {
- elog "${DRIVER} has been set as your default akonadi storage backend."
- elog "You can override it in your ~/.config/akonadi/akonadiserverrc."
- elog "Available drivers are: ${AVAILABLE}"
-}