summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/cantor')
-rw-r--r--kde-apps/cantor/Manifest1
-rw-r--r--kde-apps/cantor/cantor-19.04.1.ebuild104
2 files changed, 0 insertions, 105 deletions
diff --git a/kde-apps/cantor/Manifest b/kde-apps/cantor/Manifest
index 83e147c72684..8b5623922d76 100644
--- a/kde-apps/cantor/Manifest
+++ b/kde-apps/cantor/Manifest
@@ -1,3 +1,2 @@
DIST cantor-18.12.3.tar.xz 2515580 BLAKE2B caff71f7ec631129424f3b6e9e28b22007faaab607260359d9b3bf12f6478d773a953c9e6b918601ea74eaee6056e5b11264745e73409b3b616c8f61ec35818e SHA512 196d47adef9cb35c1816efa0a88dcf904ac7b91176bde779f84c40315732bbc1196c21dff4a6c363cbf6fc4785aaa512590638a965c79c50574b264a4d7beccf
-DIST cantor-19.04.1.tar.xz 2521404 BLAKE2B 68924bcb3f046775d886b9af4903653cc1395af0d90ad932e1667972d79b454126493764b9bee548db690c0ec56fb78a5336f6dd04b97117c84a916dd14ca2a7 SHA512 a6ae43ace5761a12157f2cfdd2dafeb5ac5cf0f0e96b4328cd7913d9168976b75133c122604f8296fb9baaae252e786a16128c2c9e1f2df4403f1bbef507493b
DIST cantor-19.04.2.tar.xz 2523164 BLAKE2B 209610fe5825aed09e42a28efd7b85e05b12dc27469030a59e2823b1865d325b323eeb8ed0a2ad19e377cf72562fbcc6e4d98c5364d628403ccdbac33723c8a7 SHA512 5792df774f6b961024b1bf484186eebc8175ec8d95e9edc8f88445c8e52f74eb08e3feb6279bb1ecab9c82d62938eb7959fed34cfb4dfd02e949b42887359f65
diff --git a/kde-apps/cantor/cantor-19.04.1.ebuild b/kde-apps/cantor/cantor-19.04.1.ebuild
deleted file mode 100644
index 181b280d4be7..000000000000
--- a/kde-apps/cantor/cantor-19.04.1.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-KDE_HANDBOOK="forceoptional"
-KDE_TEST="forceoptional"
-PYTHON_COMPAT=( python3_{5,6,7} )
-inherit kde5 python-single-r1
-
-DESCRIPTION="Interface for doing mathematics and scientific computing"
-HOMEPAGE="https://kde.org/applications/education/cantor https://edu.kde.org/cantor/"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="+analitza julia lua markdown postscript python qalculate R"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
-DEPEND="
- $(add_frameworks_dep karchive)
- $(add_frameworks_dep kcompletion)
- $(add_frameworks_dep kconfig)
- $(add_frameworks_dep kconfigwidgets)
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep kcrash)
- $(add_frameworks_dep ki18n)
- $(add_frameworks_dep kiconthemes)
- $(add_frameworks_dep kio)
- $(add_frameworks_dep knewstuff)
- $(add_frameworks_dep kparts)
- $(add_frameworks_dep kpty)
- $(add_frameworks_dep ktexteditor)
- $(add_frameworks_dep ktextwidgets)
- $(add_frameworks_dep kwidgetsaddons)
- $(add_frameworks_dep kxmlgui)
- $(add_frameworks_dep syntax-highlighting)
- $(add_qt_dep qtgui)
- $(add_qt_dep qtprintsupport)
- $(add_qt_dep qtsvg)
- $(add_qt_dep qtwidgets)
- $(add_qt_dep qtxml)
- $(add_qt_dep qtxmlpatterns)
- analitza? ( $(add_kdeapps_dep analitza) )
- julia? ( dev-lang/julia )
- lua? ( dev-lang/luajit:2 )
- markdown? ( >=app-text/discount-2.2.2 )
- qalculate? (
- sci-libs/cln
- sci-libs/libqalculate:=
- )
- postscript? ( app-text/libspectre )
- python? (
- ${PYTHON_DEPS}
- $(add_qt_dep qtdbus)
- )
- R? ( dev-lang/R )
-"
-RDEPEND="${DEPEND}"
-
-RESTRICT+=" test"
-
-pkg_pretend() {
- kde5_pkg_pretend
-
- if ! has_version sci-mathematics/maxima && ! has_version sci-mathematics/octave && \
- ! use analitza && ! use julia && ! use lua && ! use python && ! use qalculate && ! use R; then
- elog "You have decided to build ${PN} with no backend."
- elog "To have this application functional, please enable one of the backends via USE flag:"
- elog " analitza, lua, python, qalculate, R"
- elog "Alternatively, install one of these:"
- elog " # emerge sci-mathematics/maxima (bug #619534)"
- elog " # emerge sci-mathematics/octave"
- elog "Experimental available USE flag:"
- elog " julia (not stable, bug #613576)"
- elog
- fi
-
- if ! has_version virtual/latex-base; then
- elog "For LaTeX support:"
- elog " # emerge virtual/latex-base"
- fi
-}
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
- kde5_pkg_setup
-}
-
-src_configure() {
- use julia && addpredict /proc/self/mem # bug 602894
-
- local mycmakeargs=(
- -DCMAKE_DISABLE_FIND_PACKAGE_PythonLibs=ON
- $(cmake-utils_use_find_package analitza Analitza5)
- $(cmake-utils_use_find_package julia Julia)
- $(cmake-utils_use_find_package lua LuaJIT)
- $(cmake-utils_use_find_package markdown Discount)
- $(cmake-utils_use_find_package postscript LibSpectre)
- $(cmake-utils_use_find_package python PythonLibs3)
- $(cmake-utils_use_find_package qalculate Qalculate)
- $(cmake-utils_use_find_package R R)
- )
- kde5_src_configure
-}