summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/kgeography')
-rw-r--r--kde-apps/kgeography/Manifest1
-rw-r--r--kde-apps/kgeography/files/kgeography-15.12.0-kcrash.patch54
-rw-r--r--kde-apps/kgeography/files/kgeography-15.12.0-kservice.patch33
-rw-r--r--kde-apps/kgeography/kgeography-15.12.3.ebuild35
4 files changed, 123 insertions, 0 deletions
diff --git a/kde-apps/kgeography/Manifest b/kde-apps/kgeography/Manifest
index c98842b461b4..3a9cad4a56da 100644
--- a/kde-apps/kgeography/Manifest
+++ b/kde-apps/kgeography/Manifest
@@ -1 +1,2 @@
+DIST kgeography-15.12.3.tar.xz 6714820 SHA256 a628d7e8e4dd504fa7edcf3ba59287dd5ec8cbbf2a50a2fe208e4604e4cb58a7 SHA512 25ab1d6fcd58ccba9a8ff723aff8801f9a9d18e6040e0b0f9c53a7a93ec95cf50ae90f996ecb212e96589ee995566662dc908d1a7fa4858b03216873b9128d76 WHIRLPOOL e6bc867080f0297221720a1ff4518b380caa69f6a78369dd9462d80a822e15566172e2783112e90635567800491f1d67be537b380bb6fe8b2fa06fcec4a5cf22
DIST kgeography-4.14.3.tar.xz 6707392 SHA256 44b26e6f08a53b946d3884dbd08486eaed33051f202959bd1901ae19ba38a788 SHA512 a468a05240d3163e6d177fbbcfb506d26083d5571e157b071cd1f05829485ce1251037a7a38be1e05bed037fbf66af8d10f34140c25490dcb76e568403fa9974 WHIRLPOOL f4a68eae9bc96647517da8f64251397cbf9388590f052eb727129665070fd30761e8c7a20811790d36150f047bc8a53679edc5b680034c69c8f8ee4659e0ab86
diff --git a/kde-apps/kgeography/files/kgeography-15.12.0-kcrash.patch b/kde-apps/kgeography/files/kgeography-15.12.0-kcrash.patch
new file mode 100644
index 000000000000..94ee6ec262ee
--- /dev/null
+++ b/kde-apps/kgeography/files/kgeography-15.12.0-kcrash.patch
@@ -0,0 +1,54 @@
+From: Andreas Cord-Landwehr <cordlandwehr@kde.org>
+Date: Thu, 31 Dec 2015 13:02:56 +0000
+Subject: Enable KCrash.
+X-Git-Url: http://quickgit.kde.org/?p=kgeography.git&a=commitdiff&h=099cc1be8431e5e3b7109287cc0168aa35815df9
+---
+Enable KCrash.
+---
+
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -14,8 +14,8 @@
+
+ find_package (Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED Core Widgets)
+
+-find_package (KF5 REQUIRED COMPONENTS
+- XmlGui WidgetsAddons CoreAddons ConfigWidgets I18n ItemViews IconThemes Service DocTools
++find_package (KF5 5.15 REQUIRED COMPONENTS
++ XmlGui WidgetsAddons CoreAddons ConfigWidgets I18n ItemViews IconThemes Service Crash DocTools
+ )
+
+ include(KDEInstallDirs)
+
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -38,6 +38,7 @@
+ KF5::WidgetsAddons
+ KF5::CoreAddons
+ KF5::ConfigWidgets
++ KF5::Crash
+ KF5::I18n
+ KF5::ItemViews
+ KF5::IconThemes
+
+--- a/src/main.cpp
++++ b/src/main.cpp
+@@ -13,6 +13,7 @@
+ #include <qapplication.h>
+ #include <qcommandlineparser.h>
+ #include <Kdelibs4ConfigMigrator>
++#include <KCrash>
+ #include "kgeography.h"
+
+ int main(int argc, char *argv[])
+@@ -33,6 +34,8 @@
+
+ app.setWindowIcon(QIcon::fromTheme(QStringLiteral("kgeography")));
+
++ KCrash::initialize();
++
+ QCommandLineParser parser;
+ about.setupCommandLine(&parser);
+ parser.process(app);
+
diff --git a/kde-apps/kgeography/files/kgeography-15.12.0-kservice.patch b/kde-apps/kgeography/files/kgeography-15.12.0-kservice.patch
new file mode 100644
index 000000000000..3eacfb95c2e1
--- /dev/null
+++ b/kde-apps/kgeography/files/kgeography-15.12.0-kservice.patch
@@ -0,0 +1,33 @@
+commit 509c48f9040172e555e2243234bc2f8a853d80c7
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Thu Dec 31 20:39:40 2015 +0100
+
+ Remove unused dependency
+
+ REVIEW: 126586
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index f7f7b76..9c1f6c1 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -15,7 +15,7 @@ set (CMAKE_MODULE_PATH ${ECM_MODULE_PATH})
+ find_package (Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED Core Widgets)
+
+ find_package (KF5 5.15 REQUIRED COMPONENTS
+- XmlGui WidgetsAddons CoreAddons ConfigWidgets I18n ItemViews IconThemes Service Crash DocTools
++ XmlGui WidgetsAddons CoreAddons ConfigWidgets I18n ItemViews IconThemes Crash DocTools
+ )
+
+ include(KDEInstallDirs)
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 8307954..a07ba4e 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -42,7 +42,6 @@ target_link_libraries(kgeography KF5::XmlGui
+ KF5::I18n
+ KF5::ItemViews
+ KF5::IconThemes
+- KF5::Service
+ )
+ install(TARGETS kgeography EXPORT KGeography ${KDE_INSTALL_TARGETS_DEFAULT_ARGS} )
+
diff --git a/kde-apps/kgeography/kgeography-15.12.3.ebuild b/kde-apps/kgeography/kgeography-15.12.3.ebuild
new file mode 100644
index 000000000000..d022a8e0d7ad
--- /dev/null
+++ b/kde-apps/kgeography/kgeography-15.12.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Geography learning tool"
+HOMEPAGE="https://edu.kde.org/applications/miscellaneous/kgeography
+https://edu.kde.org/applications/all/kgeography"
+KEYWORDS=" ~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-15.12.0-kcrash.patch"
+ "${FILESDIR}/${PN}-15.12.0-kservice.patch"
+)