summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/kontact/kontact-4.14.11_pre20160211.ebuild')
-rw-r--r--kde-apps/kontact/kontact-4.14.11_pre20160211.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/kde-apps/kontact/kontact-4.14.11_pre20160211.ebuild b/kde-apps/kontact/kontact-4.14.11_pre20160211.ebuild
new file mode 100644
index 000000000000..4059ce84ca6f
--- /dev/null
+++ b/kde-apps/kontact/kontact-4.14.11_pre20160211.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+KMNAME="kdepim"
+EGIT_BRANCH="KDE/4.14"
+inherit kde4-meta
+
+DESCRIPTION="KDE personal information manager"
+HOMEPAGE="https://www.kde.org/applications/office/kontact/"
+COMMIT_ID="2aec255c6465676404e4694405c153e485e477d9"
+SRC_URI="https://quickgit.kde.org/?p=kdepim.git&a=snapshot&h=${COMMIT_ID}&fmt=tgz -> ${KMNAME}-${PV}.tar.gz"
+
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdeapps_dep kdepimlibs 'akonadi(+)')
+ $(add_kdeapps_dep kdepim-common-libs)
+"
+RDEPEND="${DEPEND}"
+
+KMLOADLIBS="kdepim-common-libs"
+KMSAVELIBS="true"
+
+# We remove plugins that are related to external kdepim programs. This way
+# kontact doesn't have to depend on all programs it has plugins for.
+# kcontactmanager gone from kdesvn
+#
+KMEXTRACTONLY="
+ kontact/plugins/akregator/
+ kontact/plugins/kaddressbook/
+ kontact/plugins/kjots/
+ kontact/plugins/kmail/
+ kontact/plugins/knode/
+ kontact/plugins/knotes/
+ kontact/plugins/korganizer/
+ kontact/plugins/ktimetracker/
+ kontact/plugins/planner/
+ kontact/plugins/specialdates/
+ libkdepimdbusinterfaces/
+"
+
+src_unpack() {
+ if use handbook; then
+ KMEXTRA+="
+ doc/kontact-admin/
+ "
+ fi
+
+ kde4-meta_src_unpack
+}