summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/kstars/files')
-rw-r--r--kde-apps/kstars/files/kstars-15.12.0-unused-kf5-deps.patch79
-rw-r--r--kde-apps/kstars/files/kstars-15.12.0-unused-qt-deps.patch60
2 files changed, 139 insertions, 0 deletions
diff --git a/kde-apps/kstars/files/kstars-15.12.0-unused-kf5-deps.patch b/kde-apps/kstars/files/kstars-15.12.0-unused-kf5-deps.patch
new file mode 100644
index 000000000000..0623845a20f1
--- /dev/null
+++ b/kde-apps/kstars/files/kstars-15.12.0-unused-kf5-deps.patch
@@ -0,0 +1,79 @@
+From: Akarsh Simha <akarsh@kde.org>
+Date: Thu, 31 Dec 2015 10:40:37 +0000
+Subject: [NEEDS TESTING] Remove "fake" KF5 dependencies from CMakeLists.txt
+X-Git-Url: http://quickgit.kde.org/?p=kstars.git&a=commitdiff&h=14ca537e2676267bed73a40f0b8efd94d7cbc761
+---
+[NEEDS TESTING] Remove "fake" KF5 dependencies from CMakeLists.txt
+
+Removed the following KF5 frameworks: JobWidgets, DBusAddons, TextEditor
+
+Moved the Notifications KF5 framework as required only if INDI is
+present.
+
+Builds both with and without INDI (but not in a completely thorough
+test) on my setup (ArchLinux)
+
+Jasem: please double check that it builds correctly for you too
+with/without INDI.
+
+CCMAIL: mutlaqja@ikarustech.com
+---
+
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -32,16 +32,13 @@
+ GuiAddons
+ WidgetsAddons
+ NewStuff
+- DBusAddons
++# DBusAddons
+ I18n
+ Init
+- JobWidgets
+ KIO
+ XmlGui
+ Plotting
+- TextEditor
+ IconThemes
+- Notifications
+ )
+
+ find_package(Eigen3 REQUIRED)
+@@ -61,6 +58,8 @@
+ find_package(INDI 1.2.0)
+ #FIXME is there a better way to do this?
+ if (INDI_FOUND)
++#FIXME is the following the right way of doing this?
++find_package(KF5 REQUIRED COMPONENTS Notifications)
+ SET(HAVE_INDI 1)
+ else(INDI_FOUND)
+ SET(HAVE_INDI 0)
+
+--- a/kstars/CMakeLists.txt
++++ b/kstars/CMakeLists.txt
+@@ -541,10 +541,9 @@
+ KF5::KIOFileWidgets
+ KF5::WidgetsAddons
+ KF5::Plotting
+- KF5::TextEditor
+- KF5::DBusAddons
++# KF5::TextEditor
++# KF5::DBusAddons
+ KF5::IconThemes
+- KF5::Notifications
+ Qt5::Gui
+ Qt5::PrintSupport
+ Qt5::Sql
+@@ -561,7 +560,9 @@
+ target_link_libraries(KStarsLib ${CFITSIO_LIBRARIES})
+ endif (CFITSIO_FOUND)
+ if (INDI_FOUND)
+- target_link_libraries(KStarsLib ${CMAKE_THREAD_LIBS_INIT} ${INDI_LIBRARIES} ${INDI_CLIENT_LIBRARIES} z)
++ target_link_libraries(KStarsLib ${CMAKE_THREAD_LIBS_INIT}
++ ${INDI_LIBRARIES} ${INDI_CLIENT_LIBRARIES}
++ KF5::Notifications z)
+ endif (INDI_FOUND)
+ if (WCSLIB_FOUND)
+ target_link_libraries(KStarsLib ${WCSLIB_LIBRARIES})
+
diff --git a/kde-apps/kstars/files/kstars-15.12.0-unused-qt-deps.patch b/kde-apps/kstars/files/kstars-15.12.0-unused-qt-deps.patch
new file mode 100644
index 000000000000..f819ec40decc
--- /dev/null
+++ b/kde-apps/kstars/files/kstars-15.12.0-unused-qt-deps.patch
@@ -0,0 +1,60 @@
+From: Jasem Mutlaq <mutlaqja@ikarustech.com>
+Date: Wed, 30 Dec 2015 17:02:20 +0000
+Subject: Removing unncessary dependencies on Qt modules for Test OpenGL QML QtQuick QtMultimedia. We should re-enable QML/QtQuick if someone manager to migrate what is interesting tonight tool
+X-Git-Url: http://quickgit.kde.org/?p=kstars.git&a=commitdiff&h=2f09f40aca053048ffb65621e3c18780cdc5cbe3
+---
+Removing unncessary dependencies on Qt modules for Test OpenGL QML QtQuick QtMultimedia. We should re-enable QML/QtQuick if someone manager to migrate what is interesting tonight tool
+---
+
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -16,7 +16,8 @@
+ set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH})
+ set(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules" ${CMAKE_MODULE_PATH})
+
+-find_package(Qt5 5.2 REQUIRED COMPONENTS Gui Qml Quick Xml Sql Svg OpenGL PrintSupport Multimedia Test)
++#find_package(Qt5 5.2 REQUIRED COMPONENTS Gui Qml Quick Xml Sql Svg PrintSupport)
++find_package(Qt5 5.2 REQUIRED COMPONENTS Gui Xml Sql Svg PrintSupport)
+ include(KDEInstallDirs)
+ include(KDECompilerSettings)
+ include(KDECMakeSettings)
+--- a/kstars/CMakeLists.txt
++++ b/kstars/CMakeLists.txt
+@@ -549,9 +549,8 @@
+ Qt5::PrintSupport
+ Qt5::Sql
+ Qt5::Svg
+- Qt5::Multimedia
+- Qt5::Qml
+- Qt5::Quick
++ #Qt5::Qml
++ #Qt5::Quick
+ ${ZLIB_LIBRARIES}
+ )
+
+--- a/kstars/kstars.cpp
++++ b/kstars/kstars.cpp
+@@ -39,7 +39,7 @@
+ #include "dialogs/finddialog.h"
+ #include "dialogs/exportimagedialog.h"
+ #include "observinglist.h"
+-#include "whatsinteresting/wiview.h"
++//#include "whatsinteresting/wiview.h"
+
+ #include "kstarsadaptor.h"
+
+--- a/kstars/kstarsactions.cpp
++++ b/kstars/kstarsactions.cpp
+@@ -30,8 +30,8 @@
+ #include <QDockWidget>
+ #include <QPointer>
+ #include <QInputDialog>
+-#include <QQuickWindow>
+-#include <QQuickView>
++//#include <QQuickWindow>
++//#include <QQuickView>
+ #include <QDebug>
+ #include <QAction>
+ #include <QFileDialog>
+