summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/ktp-contact-runner/ktp-contact-runner-19.08.3.ebuild')
-rw-r--r--kde-apps/ktp-contact-runner/ktp-contact-runner-19.08.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-apps/ktp-contact-runner/ktp-contact-runner-19.08.3.ebuild b/kde-apps/ktp-contact-runner/ktp-contact-runner-19.08.3.ebuild
new file mode 100644
index 000000000000..4324a7271363
--- /dev/null
+++ b/kde-apps/ktp-contact-runner/ktp-contact-runner-19.08.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.60.0
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="KDE Telepathy krunner plugin"
+HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/krunner-${KFMIN}:5
+ >=kde-apps/ktp-common-internals-${PVCUT}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ net-libs/telepathy-qt[qt5(+)]
+"
+DEPEND="${RDEPEND}
+ >=kde-frameworks/kservice-${KFMIN}:5
+"