summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/libkface/libkface-15.08.2-r1.ebuild')
-rw-r--r--kde-apps/libkface/libkface-15.08.2-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/kde-apps/libkface/libkface-15.08.2-r1.ebuild b/kde-apps/libkface/libkface-15.08.2-r1.ebuild
new file mode 100644
index 000000000000..c7dc14d0351a
--- /dev/null
+++ b/kde-apps/libkface/libkface-15.08.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="Qt/C++ wrapper around LibFace to perform face recognition and detection"
+HOMEPAGE="https://projects.kde.org/projects/kde/kdegraphics/libs/libkface"
+
+LICENSE="GPL-2"
+SLOT="4/3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/opencv-3.0.0[contrib]"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-15.08.2-opencv3.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_OPENCV3=ON
+ )
+
+ kde4-base_src_configure
+}