summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kcheckpass')
-rw-r--r--kde-base/kcheckpass/Manifest3
-rw-r--r--kde-base/kcheckpass/files/kcheckpass-4.4.2-no-SUID-no-GUID.patch15
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.11.14.ebuild33
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.11.19.ebuild33
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.11.21.ebuild33
-rw-r--r--kde-base/kcheckpass/metadata.xml5
6 files changed, 122 insertions, 0 deletions
diff --git a/kde-base/kcheckpass/Manifest b/kde-base/kcheckpass/Manifest
new file mode 100644
index 000000000000..8126fee160e2
--- /dev/null
+++ b/kde-base/kcheckpass/Manifest
@@ -0,0 +1,3 @@
+DIST kde-workspace-4.11.14.tar.xz 13529808 SHA256 cf20a562f3abf848ab0e122d6af1971dcc6383b91565f6da21f46f1011386e01 SHA512 203a5ffe1eea6f6d3e70fdcded0ac1fc86f76f8a175c043beddb5cbfaa865a07d53b6c1be55d63f4ff47946757267f390318cfad41bb0006f10462e8ec47dea7 WHIRLPOOL dd91f268701de19108eac235a12047aabf319189ce927dea1a60450183878ed454110b4a9d5bfa9613fa7732c8ac7f1344dc8cbc2d12d0b29c42b05e725183a2
+DIST kde-workspace-4.11.19.tar.xz 13547744 SHA256 1c1429db0a12d6ad076e0f1c6f1a00cac781aceb1aa8c88937fbf2700dc2c5c2 SHA512 37fad2704347bb123d05fbefe35ab73a24641baf83bc3486c2d8078ef0c601a1ef0438261040feefe8ee1d4341e7fa453d3412ccbb6e00d60ce7992ca5e5ac38 WHIRLPOOL 9a95bbad4c14988316c4c6c93738e5c945d6d4b1628c037edb46387c78abbc878ae6482ebec825257e30d5a0349e85db6261fdbf14100f798de6f2ca978a57ee
+DIST kde-workspace-4.11.21.tar.xz 13550508 SHA256 7196c68802af335b15a3b8e14c55a15ed7c2c0e9145a047dc6d4a281fe7f7c8f SHA512 6e4244177564bb497b2ab0ef5a6e98bdbc2629d8118af16d3cbb08d20d3e3cb6d9433c48c85e0b999226c02950a7a296eb2dbbb6f0bb3e1931300b18f64f5321 WHIRLPOOL c24bea247f39927aad8d80a6cf6dcb967ad4d650000877fb8d962fd9091626e49d776b2e4a99943d4ce1c40226c2827f346f5f2478d95208ba1e7ac609ff415d
diff --git a/kde-base/kcheckpass/files/kcheckpass-4.4.2-no-SUID-no-GUID.patch b/kde-base/kcheckpass/files/kcheckpass-4.4.2-no-SUID-no-GUID.patch
new file mode 100644
index 000000000000..78520d4acc4b
--- /dev/null
+++ b/kde-base/kcheckpass/files/kcheckpass-4.4.2-no-SUID-no-GUID.patch
@@ -0,0 +1,15 @@
+Index: kcheckpass/CMakeLists.txt
+===================================================================
+--- kcheckpass/CMakeLists.txt (revision 1112521)
++++ kcheckpass/CMakeLists.txt (working copy)
+@@ -23,10 +23,6 @@
+ macro_add_compile_flags(kcheckpass -U_REENTRANT)
+ target_link_libraries(kcheckpass ${KDE4_KDEFAKES_LIBS} ${UNIXAUTH_LIBRARIES} ${SOCKET_LIBRARIES})
+ install(TARGETS kcheckpass DESTINATION ${LIBEXEC_INSTALL_DIR})
+-install(CODE "
+- set(KCP_PATH \"\$ENV{DESTDIR}${LIBEXEC_INSTALL_DIR}/kcheckpass\")
+- EXECUTE_PROCESS(COMMAND sh -c \"chown root '\${KCP_PATH}' && chmod +s '\${KCP_PATH}'\")
+-")
+
+ install_pam_service(kcheckpass)
+
diff --git a/kde-base/kcheckpass/kcheckpass-4.11.14.ebuild b/kde-base/kcheckpass/kcheckpass-4.11.14.ebuild
new file mode 100644
index 000000000000..02ff0dcd7b68
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-4.11.14.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug pam"
+
+RDEPEND="
+ pam? (
+ >=kde-base/kdebase-pam-7
+ virtual/pam
+ )
+"
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ use pam && epatch "${FILESDIR}/${PN}-4.4.2-no-SUID-no-GUID.patch"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with pam)
+ )
+
+ kde4-meta_src_configure
+}
diff --git a/kde-base/kcheckpass/kcheckpass-4.11.19.ebuild b/kde-base/kcheckpass/kcheckpass-4.11.19.ebuild
new file mode 100644
index 000000000000..ff3952a0d3d6
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-4.11.19.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication"
+KEYWORDS="amd64 ~arm ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug pam"
+
+RDEPEND="
+ pam? (
+ >=kde-base/kdebase-pam-7
+ virtual/pam
+ )
+"
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ use pam && epatch "${FILESDIR}/${PN}-4.4.2-no-SUID-no-GUID.patch"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with pam)
+ )
+
+ kde4-meta_src_configure
+}
diff --git a/kde-base/kcheckpass/kcheckpass-4.11.21.ebuild b/kde-base/kcheckpass/kcheckpass-4.11.21.ebuild
new file mode 100644
index 000000000000..4904fe0b0dc7
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-4.11.21.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug pam"
+
+RDEPEND="
+ pam? (
+ >=kde-base/kdebase-pam-7
+ virtual/pam
+ )
+"
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ use pam && epatch "${FILESDIR}/${PN}-4.4.2-no-SUID-no-GUID.patch"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with pam)
+ )
+
+ kde4-meta_src_configure
+}
diff --git a/kde-base/kcheckpass/metadata.xml b/kde-base/kcheckpass/metadata.xml
new file mode 100644
index 000000000000..8d1e86a9cefb
--- /dev/null
+++ b/kde-base/kcheckpass/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>