summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/libkworkspace/libkworkspace-4.11.14.ebuild')
-rw-r--r--kde-base/libkworkspace/libkworkspace-4.11.14.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-base/libkworkspace/libkworkspace-4.11.14.ebuild b/kde-base/libkworkspace/libkworkspace-4.11.14.ebuild
new file mode 100644
index 000000000000..512c05f5fe6f
--- /dev/null
+++ b/kde-base/libkworkspace/libkworkspace-4.11.14.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KMNAME="kde-workspace"
+KMMODULE="libs/kworkspace"
+inherit kde4-meta
+
+DESCRIPTION="A library for KDE desktop applications"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+KMEXTRACTONLY="
+ ksmserver/org.kde.KSMServerInterface.xml
+ kwin/org.kde.KWin.xml
+"
+
+KMSAVELIBS="true"
+
+DEPEND="
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXau
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's/install( FILES kdisplaymanager.h/install( FILES kdisplaymanager.h screenpreviewwidget.h/' \
+ libs/kworkspace/CMakeLists.txt || die "failed to provide screenpreviewwidget.h"
+
+ kde4-meta_src_prepare
+}