summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.66.0-r1.ebuild1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.66.0.ebuild56
2 files changed, 1 insertions, 56 deletions
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.66.0-r1.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.66.0-r1.ebuild
index d81ffdb1765c..9c67c6caffb6 100644
--- a/kde-frameworks/frameworkintegration/frameworkintegration-5.66.0-r1.ebuild
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.66.0-r1.ebuild
@@ -10,6 +10,7 @@ VIRTUALX_REQUIRED="test"
inherit ecm kde.org
DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
LICENSE="LGPL-2+"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="appstream"
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.66.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.66.0.ebuild
deleted file mode 100644
index 41082d685c56..000000000000
--- a/kde-frameworks/frameworkintegration/frameworkintegration-5.66.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ECM_QTHELP="false"
-PVCUT=$(ver_cut 1-2)
-QTMIN=5.12.3
-VIRTUALX_REQUIRED="test"
-inherit ecm kde.org
-
-DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
-LICENSE="LGPL-2+"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="appstream X"
-
-# drop qtwidgets subslot operator when QT_MINIMAL >= 5.14.0
-DEPEND="
- =kde-frameworks/kconfig-${PVCUT}*:5
- =kde-frameworks/kconfigwidgets-${PVCUT}*:5
- =kde-frameworks/ki18n-${PVCUT}*:5
- =kde-frameworks/kiconthemes-${PVCUT}*:5
- =kde-frameworks/knewstuff-${PVCUT}*:5
- =kde-frameworks/knotifications-${PVCUT}*:5
- =kde-frameworks/kpackage-${PVCUT}*:5
- =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5=
- appstream? (
- app-admin/packagekit-qt
- dev-libs/appstream[qt5]
- )
- X? (
- >=dev-qt/qtx11extras-${QTMIN}:5
- x11-libs/libxcb
- )
-"
-RDEPEND="${DEPEND}"
-
-# requires running kde environment
-RESTRICT+=" test"
-
-src_prepare() {
- ecm_punt_bogus_dep Qt5 DBus
- ecm_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package appstream AppStreamQt)
- $(cmake_use_find_package appstream packagekitqt5)
- $(cmake_use_find_package X XCB)
- )
-
- ecm_src_configure
-}