summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/knewstuff')
-rw-r--r--kde-frameworks/knewstuff/Manifest1
-rw-r--r--kde-frameworks/knewstuff/knewstuff-5.71.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/kde-frameworks/knewstuff/Manifest b/kde-frameworks/knewstuff/Manifest
index 3fc1890b2f00..4156e782b63c 100644
--- a/kde-frameworks/knewstuff/Manifest
+++ b/kde-frameworks/knewstuff/Manifest
@@ -1 +1,2 @@
DIST knewstuff-5.70.0.tar.xz 1096436 BLAKE2B 1b2d59d20fba2466eee20175f4040f3aea3477cd211a51f0a5e4b419fc0c3ea48056cbb69f0e26ac01640edc27fd7585b41d67ce94c3bc038bc0f48fbbdd1e45 SHA512 10e336f99370458b791e636b254d497acd7421f109ddeedd0957bf049a15441981cf08b94626df651f459e69f05d42fc54b00a54b964a4c06fd9af3aa0bd75ac
+DIST knewstuff-5.71.0.tar.xz 1121420 BLAKE2B a53913d810fd5cf100bc0490bd320fcd323f2f121259702d9deee1e0f4ce3f4de08199c8076fb56807995f5d60d642e6236f4ff574d06221b3ea19ce70cff211 SHA512 0b5a65086d0ca08ac3288523262762e70a03a208400068409cd1c964bb805f1328a7314692164d9ab70b3e07d3438f291b8d18bca99bbdd134a3f7ea658e5297
diff --git a/kde-frameworks/knewstuff/knewstuff-5.71.0.ebuild b/kde-frameworks/knewstuff/knewstuff-5.71.0.ebuild
new file mode 100644
index 000000000000..378e297a16d0
--- /dev/null
+++ b/kde-frameworks/knewstuff/knewstuff-5.71.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.14.1
+inherit ecm kde.org
+
+DESCRIPTION="Framework for downloading and sharing additional application data"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ =kde-frameworks/attica-${PVCUT}*:5
+ =kde-frameworks/karchive-${PVCUT}*:5
+ =kde-frameworks/kcompletion-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kitemviews-${PVCUT}*:5
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/ktextwidgets-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kxmlgui-${PVCUT}*:5
+"
+RDEPEND="${DEPEND}
+ >=kde-frameworks/kirigami-${PVCUT}:5
+"