summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/akonadi-google/akonadi-google-20131213.ebuild')
-rw-r--r--kde-misc/akonadi-google/akonadi-google-20131213.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-misc/akonadi-google/akonadi-google-20131213.ebuild b/kde-misc/akonadi-google/akonadi-google-20131213.ebuild
new file mode 100644
index 000000000000..b576b16fde5b
--- /dev/null
+++ b/kde-misc/akonadi-google/akonadi-google-20131213.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_SCM="git"
+inherit kde4-base
+
+EGIT_REPO_URI="git://anongit.kde.org/akonadi-googledata-resource"
+DESCRIPTION="Google services integration in Akonadi"
+HOMEPAGE="https://projects.kde.org/projects/unmaintained/akonadi-googledata-resource"
+SRC_URI="http://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.xz"
+LICENSE="GPL-2"
+
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop(+)')
+ dev-libs/libxslt
+ dev-libs/qjson
+ >=net-libs/libkgapi-2:4
+ !>=kde-base/kdepim-runtime-4.8.50
+"
+RDEPEND=${DEPEND}
+
+src_configure() {
+ mycmakeargs=(
+ -DKCAL=OFF
+ )
+ kde4-base_src_configure
+}