summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/kio-locate/kio-locate-0.5.3-r1.ebuild')
-rw-r--r--kde-misc/kio-locate/kio-locate-0.5.3-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-misc/kio-locate/kio-locate-0.5.3-r1.ebuild b/kde-misc/kio-locate/kio-locate-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..3cceefcf0abe
--- /dev/null
+++ b/kde-misc/kio-locate/kio-locate-0.5.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+inherit kde5
+
+DESCRIPTION="Locate KIO slave"
+HOMEPAGE="http://www.kde-apps.org/content/show.php/kio-locate?content=120965"
+SRC_URI="http://www.kde-apps.org/CONTENT/content-files/120965-${P}.tar.gz"
+# See also: https://github.com/reporter123/kio-locate/commits/master
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DOCS=( AUTHORS ChangeLog )
+
+PATCHES=(
+ "${FILESDIR}/${P}-gcc-4.7.patch"
+ "${FILESDIR}/${P}-kf5port.patch"
+)
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}
+ !kde-misc/kio-locate:4
+ sys-apps/mlocate
+"