summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/kolor-manager/files')
-rw-r--r--kde-misc/kolor-manager/files/kolor-manager-1.0.2-cmake-3.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/kde-misc/kolor-manager/files/kolor-manager-1.0.2-cmake-3.patch b/kde-misc/kolor-manager/files/kolor-manager-1.0.2-cmake-3.patch
new file mode 100644
index 000000000000..a29b13e589eb
--- /dev/null
+++ b/kde-misc/kolor-manager/files/kolor-manager-1.0.2-cmake-3.patch
@@ -0,0 +1,15 @@
+INCLUDE is for loading CMake code, and this fails with a fatal error
+in CMake 3 as 'settings' is a directory
+
+Gentoo bug #537138
+--- information/CMakeLists.txt
++++ information/CMakeLists.txt
+@@ -3,8 +3,6 @@
+ find_package(KDE4 REQUIRED)
+ include_directories(${KDE4_INCLUDES} ${kolor_manager_SOURCE_DIR} ${CMAKE_CURRENT_BINARY_DIR})
+
+-INCLUDE( "../settings")
+-
+ set(kminfo_PART_SRCS
+ kminfo.cpp
+ )