summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/konstruktor')
-rw-r--r--kde-misc/konstruktor/Manifest1
-rw-r--r--kde-misc/konstruktor/files/konstruktor-0.9_beta1-multipledeclaration.patch10
-rw-r--r--kde-misc/konstruktor/konstruktor-0.9_beta1.ebuild31
-rw-r--r--kde-misc/konstruktor/metadata.xml5
4 files changed, 47 insertions, 0 deletions
diff --git a/kde-misc/konstruktor/Manifest b/kde-misc/konstruktor/Manifest
new file mode 100644
index 000000000000..b0729e933965
--- /dev/null
+++ b/kde-misc/konstruktor/Manifest
@@ -0,0 +1 @@
+DIST konstruktor-0.9-beta1.tar.bz2 722098 SHA256 2681e62ac81ab17e712c706f34f7d3954bd280389dc516a2e73606cbdf1f73ac SHA512 c80557b8e094eebcfc67432f71601bfc49a265bedf7630413cead14e4d6c86e9123b8336d0aa5ae98b46615be68c4e731bbfc892f8b3216b37467f117bc9c40f WHIRLPOOL 8618cd4dd35a0fc28c050ff316dee6955d32938ecbad47a775e888e1b55d769e1e617018c48351b05a708a75a9ec5f72e3cddd2d530ce3454c97a82378c917f4
diff --git a/kde-misc/konstruktor/files/konstruktor-0.9_beta1-multipledeclaration.patch b/kde-misc/konstruktor/files/konstruktor-0.9_beta1-multipledeclaration.patch
new file mode 100644
index 000000000000..afccd147d52e
--- /dev/null
+++ b/kde-misc/konstruktor/files/konstruktor-0.9_beta1-multipledeclaration.patch
@@ -0,0 +1,10 @@
+--- konstruktor-0.9-beta1/src/app/renderwidget.cpp
++++ konstruktor-0.9-beta1/src/app/renderwidget.cpp
+@@ -395,7 +395,6 @@
+
+ glBegin(GL_POINTS);
+
+- int i = 0;
+ for (ldraw::model::const_iterator it = currentModel_->elements().begin(); it != currentModel_->elements().end(); ++it) {
+ if ((*it)->get_type() == ldraw::type_ref) {
+ ldraw::element_ref *r = CAST_AS_REF(*it);
diff --git a/kde-misc/konstruktor/konstruktor-0.9_beta1.ebuild b/kde-misc/konstruktor/konstruktor-0.9_beta1.ebuild
new file mode 100644
index 000000000000..c83d0691740b
--- /dev/null
+++ b/kde-misc/konstruktor/konstruktor-0.9_beta1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="${P/_/-}"
+OPENGL_REQUIRED="always"
+inherit kde4-base
+
+DESCRIPTION="LEGO CAD"
+HOMEPAGE="http://konstruktor.influx.kr/"
+SRC_URI="http://konstruktor.influx.kr/${MY_P}.tar.bz2"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="test"
+
+DEPEND="dev-db/sqlite:3"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.9_beta1-multipledeclaration.patch" )
+
+S=${WORKDIR}/${MY_P}
+
+pkg_postinst() {
+ elog "You still need to obtain ldraw data files."
+ elog "Because they are not distributable you need to download them from:"
+ elog " http://www.ldraw.org/Downloads-req-viewdownload-cid-1.html"
+}
diff --git a/kde-misc/konstruktor/metadata.xml b/kde-misc/konstruktor/metadata.xml
new file mode 100644
index 000000000000..8d1e86a9cefb
--- /dev/null
+++ b/kde-misc/konstruktor/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>