summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/kscreen/kscreen-5.15.4.ebuild')
-rw-r--r--kde-plasma/kscreen/kscreen-5.15.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-plasma/kscreen/kscreen-5.15.4.ebuild b/kde-plasma/kscreen/kscreen-5.15.4.ebuild
new file mode 100644
index 000000000000..1210d802105b
--- /dev/null
+++ b/kde-plasma/kscreen/kscreen-5.15.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="KDE Plasma screen management"
+HOMEPAGE="https://cgit.kde.org/kscreen.git"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep plasma)
+ $(add_plasma_dep libkscreen)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative 'widgets')
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ $(add_qt_dep qtgraphicaleffects)
+"
+
+# bug #580440, last checked 5.6.3
+RESTRICT+=" test"