summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/kscreenlocker')
-rw-r--r--kde-plasma/kscreenlocker/files/kde-np.pam10
-rw-r--r--kde-plasma/kscreenlocker/files/kde.pam11
-rw-r--r--kde-plasma/kscreenlocker/files/kscreenlocker-5.4.90-no-SUID-no-GUID.patch16
3 files changed, 37 insertions, 0 deletions
diff --git a/kde-plasma/kscreenlocker/files/kde-np.pam b/kde-plasma/kscreenlocker/files/kde-np.pam
new file mode 100644
index 000000000000..f5499e6dc45f
--- /dev/null
+++ b/kde-plasma/kscreenlocker/files/kde-np.pam
@@ -0,0 +1,10 @@
+#%PAM-1.0
+
+auth required pam_nologin.so
+auth required pam_permit.so
+
+account include system-local-login
+
+password include system-local-login
+
+session include system-local-login
diff --git a/kde-plasma/kscreenlocker/files/kde.pam b/kde-plasma/kscreenlocker/files/kde.pam
new file mode 100644
index 000000000000..24d19de0d3d8
--- /dev/null
+++ b/kde-plasma/kscreenlocker/files/kde.pam
@@ -0,0 +1,11 @@
+#%PAM-1.0
+
+auth required pam_nologin.so
+
+auth include system-local-login
+
+account include system-local-login
+
+password include system-local-login
+
+session include system-local-login
diff --git a/kde-plasma/kscreenlocker/files/kscreenlocker-5.4.90-no-SUID-no-GUID.patch b/kde-plasma/kscreenlocker/files/kscreenlocker-5.4.90-no-SUID-no-GUID.patch
new file mode 100644
index 000000000000..dc26f5f8922a
--- /dev/null
+++ b/kde-plasma/kscreenlocker/files/kscreenlocker-5.4.90-no-SUID-no-GUID.patch
@@ -0,0 +1,16 @@
+diff --git a/kcheckpass/CMakeLists.txt b/kcheckpass/CMakeLists.txt
+index a63fa1403e897e70989dc2e1ba7eed4bc69cbb51..12d1bfb3c690eca1acf344045a92eb942669da83 100644
+--- a/kcheckpass/CMakeLists.txt
++++ b/kcheckpass/CMakeLists.txt
+@@ -22,10 +22,6 @@ endif ()
+
+ set_property(TARGET kcheckpass APPEND_STRING PROPERTY COMPILE_FLAGS " -U_REENTRANT")
+ target_link_libraries(kcheckpass ${UNIXAUTH_LIBRARIES} ${SOCKET_LIBRARIES})
+-install(TARGETS kcheckpass DESTINATION ${KDE_INSTALL_LIBEXECDIR})
+-install(CODE "
+- set(KCP_PATH \"\$ENV{DESTDIR}${KDE_INSTALL_LIBEXECDIR}/kcheckpass\")
+- execute_process(COMMAND sh -c \"chown root '\${KCP_PATH}' && chmod +s '\${KCP_PATH}'\")
+-")
++install(TARGETS kcheckpass DESTINATION ${LIBEXEC_INSTALL_DIR})
+
+ #EXTRA_DIST = README