summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.9.5.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 9f595c1734f1..63f54f5e070d 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.8.6.tar.xz 19460 SHA256 0f195e6344b17cacb8ee0499c36f911970edd968b6dbbc008ccff4b659132179 SHA512 7d2918b95f14f41dc1b348a66a39f2d739c01e8061136aa97f27612c18fe85f779dcff7df82c22450869f31c94f71e3f5eae743cb976c0e6e6d0692db2dc450d WHIRLPOOL 5237e9409904382cf79e8caae65c2b6d730141d04acd2e643c5ac7aac04d9707a0a459a343f1c485ccb10a7abf36a90f5bbbe47ab73d1796fd03fd5ffcc5dc33
DIST ksshaskpass-5.9.4.tar.xz 20072 SHA256 6a5adce31ed348a2838b574774199102aeacec0c3ee2cfd8b5c3a588622935f0 SHA512 07e235d797bad7b3f5421f46a0688037f7b1ed6b41b94eefd1b22bc9ea4aefb9aee25f8b3cc130eeb8c0703bc6a90d24ab818a9a17dec01aed0de056c03ee4b3 WHIRLPOOL abd860c6953ac21ea2af465118df810cf81299548a205b15ccdfb627e2e60f7f946bd81b4a9a2c3170e8df1028ecb94058127c881fed72a408b957fc9c16019c
+DIST ksshaskpass-5.9.5.tar.xz 20152 SHA256 21bed81030113b5e2f4b6b363128bed7ca98b49880319c7b615e6862986b9ec6 SHA512 e851a2f852734976faaa5e8ec7fbf760ad493a8bb8effe8a0792ace51d59729823149cc4dc7bb79459a4e6e8e46372cf3b5a822f05ab87af4df2d544d77d88aa WHIRLPOOL d9b07a6e5db7b42a1c42100d93b4f1ad5937fcb064be8fdf87dabaae1bd4c2053c6bba61848791a9a94b5c4857fa2af83596f811359bb183f149f679dd8ad019
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.9.5.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.9.5.ebuild
new file mode 100644
index 000000000000..468b1b597c06
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.9.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://projects.kde.org/projects/kde/workspace/ksshaskpass"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="
+ ${DEPEND}
+ !kde-plasma/ksshaskpass:4
+"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/10-agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/10-agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/05-ksshaskpass.sh"
+ elog ""
+}